Compile Date

 Compile Date: 2003-01-04


Copyright

Information in this document, including URL and other Internet Web site references, is subject to change without notice. The entire risk of the use or the results of the use of this document remains with the user. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places, and events depicted herein are fictitious and no association with any real company, organization, product, domain name, e-mail address, logo, person, place, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

All public network IDs or addresses referenced in this document are for demonstration/example purposes only. Microsoft's inclusion of such IDs and addresses in this document does not grant you any express or implied right to test or otherwise use or access any such network ID or address.

The links in this area will let you leave Microsoft's product and/or Web site. The linked sites are not under the control of Microsoft and Microsoft is not responsible for the contents of any linked site or any link contained in a linked site, or any changes or updates to such sites. Microsoft is not responsible for webcasting or any other form of transmission received from any linked site. Microsoft is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Microsoft of the site.

For your convenience, Microsoft may make available on this service or in its software products, tools and utilities for use and/or download. Microsoft does not make any assurances with regard to the accuracy of the results or output that derives from such use of any such tools and utilities. Please respect the intellectual property rights of others when using the tools and utilities made available on this service or in Microsoft software products.

© 1985-2003 Microsoft Corporation. All rights reserved.

Active Desktop, Active Directory, ActiveMovie, ActiveX, Authenticode, BackOffice, Direct3D, DirectAnimation, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, DoubleSpace, DriveSpace, FrontPage, IntelliMirror, IntelliMouse, JScript, Microsoft, Microsoft Press, Microsoft QuickBasic, MSDN, MS-DOS, MSN, Natural, NetMeeting, OpenType, Outlook, PowerPoint, SideWinder, Visual Basic, Visual C++, Visual FoxPro, Win32, Windows, Windows Media, Windows NT, and Wingdings are either registered trademarks or trademarks of Microsoft Corporation in the U.S.A. and/or other regions and/or countries.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.

Acknowledgements

Portions of this product are based in part on the work of Mark H. Colburn and sponsored by the USENIX Association. Copyright © 1989 Mark H. Colburn. All rights reserved.

This product includes software developed by the University of California, Berkeley and its contributors.

Portions of this product are based in part on the work of the Regents of the University of California, Berkeley and its contributors. Because Microsoft has included the Regents of the University of California, Berkeley, software in this product, Microsoft is required to include the following text that accompanied such software:

Copyright © 1985, 1988 Regents of the University of California. All rights reserved.

Redistribution and use in source and binary forms are permitted provided that the above copyright notice and this paragraph are duplicated in all such forms and that any documentation, advertising materials, and other materials related to such distribution and use acknowledge that the software was developed by the University of California, Berkeley. The name of the University may not be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED "AS IS" AND WITHOUT ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR A PARTICULAR PURPOSE.

Portions of this product are based in part on the work of Greg Roelofs. Because Microsoft has included the Greg Roelofs software in this product, Microsoft is required to include the following text that accompanied such software:

Copyright © 1998-1999 Greg Roelofs. All rights reserved.

This software is provided "as is," without warranty of any kind, express or implied. In no event shall the author or contributors be held liable for any damages arising in any way from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

  1. Redistributions of source code must retain the above copyright notice, disclaimer, and this list of conditions.
  2. Redistributions in binary form must reproduce the above copyright notice, disclaimer, and this list of conditions in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgment:

This product includes software developed by Greg Roelofs and contributors for the book, PNG: The Definitive Guide, published by O'Reilly and Associates.

Portions of this software are based in part on the work of Hewlett-Packard Company. Because Microsoft has included the Hewlett-Packard Company software in this product, Microsoft is required to include the following text that accompanied such software:

Copyright © 1994 Hewlett-Packard Company

Permission to use, copy, modify, distribute and sell this software and its documentation for any purpose is hereby granted without fee, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation. Hewlett-Packard Company makes no representations about the suitability of this software for any purpose. It is provided "as is" without express or implied warranty.

Portions of this software are based in part on the work of the University of Southern California. Because Microsoft has included the University of Southern California software in this product, Microsoft is required to include the following text that accompanied such software:

Copyright © 1996 by the University of Southern California. All rights reserved.

Permission to use, copy, modify, and distribute this software and its documentation in source and binary forms for any purpose and without fee is hereby granted, provided that both the above copyright notice and this permission notice appear in all copies – and that any documentation, advertising materials, and other materials related to such distribution and use acknowledge that the software was developed in part by the University of Southern California, Information Sciences Institute. The name of the University may not be used to endorse or promote products derived from this software without specific prior written permission.

THE UNIVERSITY OF SOUTHERN CALIFORNIA makes no representations about the suitability of this software for any purpose. THIS SOFTWARE IS PROVIDED "AS IS" AND WITHOUT ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

Portions of this software are based in part on the work of Luigi Rizzo. Because Microsoft has included the Luigi Rizzo software in this product, Microsoft is required to include the following text that accompanied such software:

© 1997-98 Luigi Rizzo (luigi@iet.unipi.it)

Portions derived from code by Phil Karn (karn@ka9q.ampr.org), Robert Morelos-Zaragoza (robert@spectra.eng.hawaii.edu) and Hari Thirumoorthy (harit@spectra.eng.hawaii.edu), Aug 1995

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Portions of this software are based in part on the work of Massachusetts Institute of Technology. Because Microsoft has included the Massachusetts Institute of Technology software in this product, Microsoft is required to include the following text that accompanied such software:

Copyright © 1989,1990 by the Massachusetts Institute of Technology. All Rights Reserved.

WITHIN THAT CONSTRAINT, permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation, and that the name of M.I.T. not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. M.I.T. makes no representations about the suitability of this software for any purpose. It is provided "as is" without express or implied warranty.

Under U.S. law, this software may not be exported outside the US without license from the U.S. Commerce department.

Portions of this software are based in part on the work of Regents of The University of Michigan. Because Microsoft has included the Regents of The University of Michigan software in this product, Microsoft is required to include the following text that accompanied such software:

Copyright © 1995,1996 Regents of The University of Michigan. All Rights Reserved.

Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appears in all copies and that both that copyright notice and this permission notice appear in supporting documentation, and that the name of The University of Michigan not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. This software is supplied as is without expressed or implied warranties of any kind.


Windows Server 2003, Enterprise Edition, Help

Welcome

  • Roadmap to help and information
  • Choosing the features that are most useful
    for your server
  • Common administrative tasks
  • Troubleshooting strategies
  • New ways to do familiar tasks
  • Checklists
  • Best practices
  • Submit product feedback to Microsoft
  • Features unavailable on 64-bit versions of the
    Windows Server 2003 family

Microsoft Windows Server 2003, Enterprise Edition, logo

© 1985-2003 Microsoft Corporation.
All rights reserved. * Acknowledgements.


Best practices

This section contains pointers to product support recommendations and product tips.

A

Active Directory

Active Directory Domains and Trusts

Active Directory Schema

Active Directory Sites and Services

Active Directory Users and Computers

Active Directory: assigning permissions on Active Directory objects

Auditing security events

B

Backup

C

Certificate Services

Certificate Templates

Connection Point Services (CPS)

D

Disaster recovery

Disk Defragmenter

Disk Management

Disk quotas

Distributed File System (DFS)

DHCP

DNS

E

Encrypting File System (EFS)

Emergency Management Services: implementing security measures

Emergency Management Services: selecting and configuring hardware

Emergency Management Services: using in-band tools

I

Installing Windows Server 2003, Enterprise Edition

Internet Authentication Service (IAS)

Internet Protocol security (IPSec)

L

Licensing

Local Users and Groups

M

Modems

Monitoring performance

N

Network Connections

Network Load Balancing clusters

Network Monitor

Novell NetWare integration: Client Service for NetWare

Novell Netware integration: NWLink

P

Passwords

Performance Logs and Alerts

Permissions and user rights

Permissions: Assigning permissions on Active Directory objects

Printing

R

Registry

Remote access

Remote Administration

Remote Desktop for Administration

Remote Installation Services (RIS)

Remote Storage

Removable Storage

Routing

S

Security

Security Configuration and Analysis

Security events: auditing

Security Settings

Security Templates

Server clusters

Services

Services for Macintosh

Shared Folders

Shutdown Event Tracker

Simple Network Management Protocol (SNMP)

Software restriction policies

Stored User Names and Passwords

System Monitor

T

TCP/IP

Telephony

Telnet

Terminal Server

Terminal Services user properties

Time Service

U

Upgrading the operating system

User profiles

User rights and permissions

V

Virtual private networks (VPNs)

W

Windows ATM services

Windows registry

WINS


Checklists

A checklist describes the steps required to set up, configure, or implement a XOX, component. Each step refers you to background information or instructions that are needed to complete the step. To perform a task, find the component in the following table and click the checklist.

XOX, offers all the features of XOX, as well as enhanced memory support, support for additional processors, and clustering. To learn more about memory support, see Enterprise Memory Architecture. To find checklists for Network Load Balancing clusters and server clusters, see Clustering in the following table.

Component | Checklist
Active Directory | Active Directory checklists
Backing up and restoring data | Checklists for backing up and restoring data
Certificate Services Creating a certification hierarchy with an offline root certification authority
Configuring certificate autoenrollment
Clustering Enabling and configuring Network Load Balancing
Creating server clusters
Installing server cluster resources
Preparation for upgrading a cluster
Preparation for installing a cluster
Configuring your server Configuring the typical setup for a first server
Connection Point Services (CPS) | CPS checklists
DHCP | DHCP checklists
Disk Defragmenter | Defragmenting volumes
Disk Management | Adding a new disk
Disk quotas | Setting up disk quotas
Distributed File System (DFS) | Creating a distributed file system
DNS | DNS checklists
Enterprise Memory Architecture Enabling application memory tuning
Enabling Physical Address Extension (PAE) x86
Installing and upgrading Performing an upgrade
Performing a new installation
Preparation for upgrading a cluster
Preparation for installing a cluster
Internet Authentication Service (IAS) | IAS checklists
IP version 6 | Installing and configuring IPv6
Licensing | Licensing checklists
Managing security templates | Securing computers using Security Configuration Manager
Message Queuing Installation for Message Queuing servers
Installation for Message Queuing clients
Modems | Installing and configuring modems
Network Connections Configuring network connections
Setting up a home or small office network
Network Load Balancing clusters | Enabling and configuring Network Load Balancing
Network Monitor | Monitoring network traffic on your local computer
Novell NetWare integration | Novell NetWare integration checklists
Printing | Setting up a printer
Remote Installation Services (RIS) | Installing Remote Installation Services
Remote Storage | Setting up Remote Storage
Removable Storage | Configure Removable Storage
Routing and Remote Access Installing and configuring the remote access server
Installing and configuring the router
Security Securing computers using Security Configuration Manager
Setting up object access auditing
Server clusters Preparation for installing a cluster
Preparation for upgrading a cluster
Planning and creating a server cluster
Validating your clustering system
Creating a new group
Creating a new resource
Creating a server cluster application server
Creating a server cluster file server
Creating a server cluster print server
Creating a server cluster virtual server
Creating a clustered IIS Web or FTP service
Installing a DHCP Service resource
Installing a Distributed File System (DFS) root resource
Installing a Distributed Transaction Coordinator resource
Installing a File Share resource
Installing a Generic Application resource
Installing a Generic Script resource
Installing a Generic Service resource
Installing a Local Quorum resource
Installing a Majority Node Set resource
Installing a Message Queuing resource
Installing a Network Name resource
Installing a Physical Disk resource
Installing a Print Spooler resource
Installing a WINS Service resource
Installing an IIS Server Instance resource
Installing an IP Address resource
Services for Macintosh | Services for Macintosh checklists
Smart card setup | Deploying smart cards for logging on to Windows
SNMP service | Implementing the SNMP service
Software restriction policies | Using software restriction policies to help protect your computer against an e-mail virus
Stored User Names and Passwords | Using Stored User Names and Passwords safely
System recovery Safeguarding your system
Recovering a system that will not start
Restoring data
TCP/IP | Configuring TCP/IP
Telephony | Telephony checklists
Terminal Server | Setting up Terminal Server
Virtual private networks (VPNs) | VPN checklists
Windows ATM services | Installing ATM services
WINS service | Installing a WINS server


New ways to do familiar tasks

Many components have changed names or locations since Windows NT 4.0 and Windows 2000. To find the new way to do a task, click the letter that the name of the component starts with, and then click the name of the component.

A

Active Directory

Active Directory Domains and Trusts

Active Directory Sites and Services

Active Directory Users and Computers

AppleTalk network integration

B

Backup (system restore)

Backup (tape devices)

Backup or Restore Wizard

C

CD Player

Client Service for NetWare

Cluster Administrator

Command-line tools

D

Device Manager

Devices

DHCP

DHCP Manager

Dial-Up Networking

Disk Administrator

Disk Management

DNS

DNS Manager

F

Find

Find computer

Find files or folders

Find printers

Folder Options

H

Hyperterminal

I

Inbox

Internet

Internet Options

L

Licensing

Log files

M

MacFile

Manage users and computers

Media Player

Message Queuing

Modems

MS-DOS commands

MSMQ Explorer

Multimedia

My Briefcase

N

Network Connections

Network Load Balancing Manager

Network Monitor

Novell NetWare

NWLink

O

Outlook Express

P

Performance Logs and Alerts

Phone and Modem Options

Ports

Printing

Printers and Faxes

Protocols (TCP/IP)

Protocols (Virtual private networks (VPNs))

R

Regional Settings

Regional and Language Options

Remote access

Remote Desktop

Routing

Routing and RAS Admin

Routing and Remote Access

S

SCSI

SCSI adapters

Security

Server

Server clusters

Server Manager

Services for Macintosh

Shared Folders

Simple Network Management Protocol (SNMP)

Sounds

Sounds and Audio Devices

System Monitor

T

Tape devices

Tcmsetup command

TCP/IP

Telephony

Terminal Services

Terminal Services in Remote Administration Mode

U

User Manager

User profiles

V

View Options

Virtual private networks (VPNs)

W

Windows Media Player

WINS

Wlbs


Troubleshooting A-Z

This section contains pointers to troubleshooting information available in Help. For more information about how to obtain product support, see Microsoft Product Support Services.

A

Active Directory

Audio

B

Backing up and restoring data

C

Cameras

CD-burning

Certificate Services

Compatibility

Connection Manager Administration Kit (CMAK)

Connection Point Services (CPS)

D

DHCP

Disk Defragmenter

Disk Management

Disk quotas

DNS

E

Emergency Management Services

Encrypting File System

Enterprise Memory Architecture

Event Viewer

H

HyperTerminal

I

Imaging

Internet Authentication Service (IAS)

Internet Information Services

Internet Protocol security (IPSec)

L

Licensing

Local Users and Groups

M

Message Queuing

Microsoft Management Console

Modems

N

Network Connections

Network Diagnostics

Network Load Balancing clusters

Network Monitor

Novell NetWare integration

P

Performance

Printing

R

Remote access

Remote Desktop

Remote Installation Services

Remote Storage

Removable Storage

Routing

S

Scanners

Security Templates

Server clusters

Services for Macintosh

Shared Folders

Shutdown Event Tracker

SNMP

Software Restriction Policies

STOP messages

Stored User Names and Passwords

System Monitor

T

Task Scheduler

TCP/IP

Telephony

Terminal Server

Time service

V

Virtual private networks

W

Windows ATM services

Windows Installer

WINS

Wireless Networking


Submit product feedback to Microsoft

You can help Microsoft target improvement efforts by submitting feedback about improvements for existing products, suggestions for additional features, and ways to make products easier to use. To submit feedback, see Product Feedback at the Microsoft Web site. (http://www.microsoft.com/)

Note

  • By offering suggestions through the Product Feedback Web site, you give Microsoft full permission to use them freely. It is not guaranteed that the suggestions will be used, but they will be reviewed for use in future products. Due to the volume and variety of suggestions, Microsoft cannot provide compensation or personal responses to each suggestion. Although it may help to contact you to get further feedback, do not feel obligated to provide an e-mail address or other personal information. Your input is appreciated, and Microsoft looks forward to building better products with helpful ideas such as yours.


Features unavailable on 64-bit versions of the Windows Server 2003 family

The 64-bit versions of XOX, and XOX, do not include certain features that are included in the 32-bit versions of those operating systems.

These features are not included because of underlying differences between the 32-bit and 64-bit architectures or because the features are not appropriate in the environments where the 64-bit versions of XOX, and XOX, are deployed.

While there might be references to these features in Help and Support Center or in other Help material, the features themselves have been removed.

The following list identifies features that are not available in the 64-bit versions of XOX, and XOX.

List of unavailable features

  • 16-bit, DOS-based subsystem
  • ACPI 2.0
    • ACPI 2.0 64-bit fixed tables are supported.
  • ASP .NET State Service
  • Compressed (zipped) Folders
  • DirectMusic
  • DVD video playback support
  • Enterprise Memory Architecture
  • Fast User Switching
  • Fax support
  • Hot Add Memory
  • IEEE 1394 audio support
  • Internet Connection Sharing (ICS)
  • Internet Connection Firewall (ICF)
  • Internet Locator Service (ILS)
  • Earlier transports:
    • IPX/SPX LAN and WAN
    • Client Service for NetWare
    • Services for Macintosh
    • NetBIOS
    • Open Shortest Path First (OSPF)
    • Simple Network Management Protocol (SNMP) over IPX/SPX
  • .NET Framework
  • NetMeeting
  • Network Bridge
  • Network Setup Wizard
  • Recovery Console (installed as a Startup option)
    • Recovery Console is accessible from the product CD.
  • Remote Assistance
  • Server Appliance Kit (SAK)
  • Speech recognition
  • Themes
  • Windows Media Player
  • Windows Media Services
  • Windows Product Activation


Overview of Windows Server 2003, Web Edition

XOX, is a part of the Microsoft® Windows® Server 2003 family. It is an easy-to-deploy, easy-to-manage server operating system that is optimized to be a complete Web hosting package.

XOX, includes the following features:

  • Internet Information Services (IIS) 6.0, which provides a robust architecture for building and publishing secure Web applications
  • Revolutionary Microsoft ASP.NET, for deploying Web services and applications rapidly
  • Remotely administered management, with an easy-to-use, task-driven, internationalized Web user interface (UI)
  • Remote Desktop for Administration, which provides remote access to the desktop of any computer running a product in the Windows Server 2003 family
  • Web Interface for Remote Administration, for configuring and managing a server from a remote client, including creating and deleting Web sites, configuring network settings, setting disk quotas, managing local user accounts, and restarting the Web server
  • Flexibility to use Microsoft Management Console (MMC) and scripting, using Windows Management Instrumentation (WMI) for detailed control and management
  • Web Distributed Authoring and Versioning (WebDAV), so that users can easily publish, manage, and share information over the Web
  • Additional wizards to make it easier for administrators to set up and manage secure authentication and Secure Sockets Layer (SSL) security
  • Improved CPU throttling, which helps organizations to allocate CPU resources on a per-site basis
  • Scalability through Network Load Balancing
  • Reliability and security improvements for the entire Windows Server 2003 family

Because XOX, is optimized for Web serving and hosting, the following features are not included:

  • Server clusters
  • Terminal Server (Note that Remote Desktop for Administration is available.)
  • File Server for Macintosh and Print Server for Macintosh
  • Infrared (IR) support
  • Printer and fax sharing
  • Internet Authentication Service (IAS)
  • Remote Storage
  • Remote Installation Services (RIS)
  • Universal Description, Discovery, and Integration (UDDI) services
  • Windows Media Services

A server running XOX, cannot be established as a domain controller, and it cannot be configured as a host for other server applications, such as Certificate Services, Microsoft Exchange Server, or Microsoft SQL Server.

Virtual private network (VPN) connections are limited to one per media type: local area network (LAN), remote access (dial-up), and direct cable connection. Server Message Block (SMB) connections are limited to 10 simultaneous connections.

Notes

  • The feature limitations in this topic apply only to computers running the XOX, operating system. If you enable Web services, such as IIS, on a computer running XOX, or XOX, the feature limitations in this topic do not apply.
  • For the latest product information, see Windows Update at the Microsoft Web site (http://www.microsoft.com/). Windows Update is a catalog of items, such as drivers, patches, the latest Help files, and Internet products, that you can download to keep your computer up to date.