Remote Administration

Using tools included with Microsoft® Windows® Server 2003 family operating systems CDs, you can remotely manage your system servers running Microsoft® Windows 2000 and Windows Server 2003 family operating systems. You can also remotely manage Windows Server 2003 family operating systems from a computer using XOX.

  • For general information, see Remote administration overview.
  • For tips about managing your server remotely, see Best practices.
  • For other sources of information, see Resources.


Remote administration overview

The following table presents remote management tasks and links to information about the tools. Unless indicated otherwise, these tools are used on Microsoft® Windows® Server 2003 family operating systems and, in some cases, XOX.

Task | Tools | Comments
Manage several servers by performing similar tasks. Microsoft Management Console;
Author an MMC console file;
Work with MMC and saved console files 		You can use appropriate saved MMC consoles, if available, or you can create custom MMC consoles for tasks you frequently either delegate or perform.
Log onto one computer remotely and manage it as if you were there. | Using Remote Desktop Connection | In addition to Windows Server 2003 family operating systems, this feature can be used with Microsoft® Windows 2000 Server. The Remote Desktop feature must be enabled on the remote computer.
Switch among several computers that you want to log on to remotely. | Remote Desktops Snap-in | In addition to Windows Server 2003 family operating systems, this feature can be used with Windows 2000 Server. The Remote Desktop feature must be enabled on the remote computer.
Administer a server running Windows Server 2003 from any computer on your network. | Remote Desktop for Administration | In addition to Windows Server 2003 family operating systems, this feature can be used with Windows 2000 Server. The Remote Desktop feature must be enabled on the remote computer.
Manage servers from XOX. Windows Server 2003 Administration Tools Pack Overview;
Remote Desktop Connection 		Windows Server 2003 Administration Tools Pack must be installed on XOX to permit server management using these tools. The Remote Desktop feature must be enabled on servers to permit use of the Remote Desktop Connection.
Manage your web server using a Web browser on a remote computer. | Using Web Interface for Remote Administration | Use Internet Explorer, version 6 or later, for remote administration using Web Interface. Web Interface is not installed by default for Web servers.
Assist in real time an operator on a remote computer running Windows Server 2003 family operating system, XOX or XOX. | Administering Remote Assistance | The Remote Assistance connection requires explicit permission from the connected user, and both computers must be running XOX or Windows Server 2003 family operating systems.
Connect to a remote computer when that computer cannot access a network or is not in a functional state because of hardware or software failure. | Telnet | All commands must be entered through the command line. Capabilities are limited, and security is minimal.
Manage disk space on servers by copying files to a library of magnetic tapes or magneto-optical disks. | Remote Storage | Some Windows components require configuration before they can be used and will be displayed in the Add or Remove Windows Components in Add or Remove Programs in Control Panel. Remote storage requires installation.

Notes

  • Depending on the Group Policy settings on your network, you might not be able to perform some of these tasks.
  • You can use command-line tools to automate many processes and tasks. For more information, see Automating processes and tasks.
  • You must physically access each computer to reboot, change hardware, and enable the Remote Desktop feature. Once the Remote Desktop feature has been enabled, it will remain enabled.
  • For an explanation of the various Remote Desktop terminologies, see Remote Administration Using Terminal Services.
  • For more information about remote administration, see the following:
      • Common Administrative Tasks
      • New features
      • Quick guide for finding tools
      • Resources


Best practices

To perform many tasks on a single, remote server, use Remote Desktop for Administration.

  • To remotely administer a server running a Windows Server 2003 family operating system, you do not need to install Terminal Server. Instead, use Remote Desktop for Administration. On these operating systems, Remote Desktop for Administration is on by default but is not enabled. After you enable remote connections, Remote Desktop for Administration allows you to administer your server from any computer on your network running Windows Server 2003 family, XOX, and Windows 2000. Windows Server 2003, Web Edition, does not support remote administration.
  • You can use Remote Desktop with Windows 2000 Server. You need to install Terminal Services for Remote Administration as described in the Windows 2000 Help.

    • For more information, see To enable or disable remote connections and Remote Desktop for Administration.

To do similar tasks on many servers, use MMC snap-ins.

  • Most of the administration tools provided with Windows Server 2003 family operating systems are Microsoft Management Console (MMC) snap-ins that can be used to administer remote servers as well as your local computer. The advantages of using MMC include the following:
    • You can create a console with the tools you use for the tasks you do most often.
    • You can set the focus for a tool to any of the servers you administer, and switch between servers and tools within a single MMC console.

    For more information, see Microsoft Management Console.

To manage servers running Windows Server 2003 family operating systems from a computer using XOX, use Windows Server 2003 Administration Tools Pack

  • Windows Server 2003 Administration Tools Pack when installed on XOX (ordinarily a client operating system) provides many remote management tools for managing your servers.
  • Windows Server 2003 Administration Tools Pack comes as adminpak.msi on the Windows Server 2003 family operating system and is easily installed from the server CD onto XOX by installing the .msi from the server to the XP Professional operating system.
  • The Administration Tools Packs in the Windows Server 2003 family and Windows 2000 are not mutually compatible. You must use the Windows 2000 Administrative Tools to administer Windows 2000, and the Windows Server 2003 Administration Tools Pack to administer the Windows Server 2003 family operating system.

    • For more information, see Windows Server 2003 Administration Tools Pack Overview.


Resources

The following resources provide additional information about remote administration.

Windows Server 2003 Resource Kit

The Microsoft Windows Server 2003 Resource Kit contains additional tools that you can use for remote administration.

    • Microsoft Windows Server 2003 Resource Kit (http://www.microsoft.com/)
    • Windows Server Resource Kit Directory Services Guide (http://www.microsoft.com/)
    • Windows Server Resource Kit Server Management Guide, Part Two: Remote Operations (http://www.microsoft.com/)
    • Remote Administration: Overview (http://www.microsoft.com/)
    • Remote Management Tools (http://www.microsoft.com/)

Microsoft Platform Software Development Kits (SDK)

For technical information about Active Directory Scripting Interfaces (ADSI), Microsoft Management Console (MMC), Windows Management Instrumentation (WMI) Software Development Kits (SDK), see the Microsoft Web site (http://www.microsoft.com).

TechNet

TechNet is a service that contains resources for information technology (IT) professionals. This includes access to articles written by support professionals at Microsoft, career and industry information, discussion groups, technical feedback, and software.

For more information, see Microsoft TechNet (http://www.microsoft.com/technet).