Novell NetWare integration

You can use tools provided with the Microsoft® Windows® Server 2003 family to access resources on Novell NetWare networks:

  • Before you install the NWLink IPX/SPX/NetBIOS Transport Protocol (NWLink) or Client Service for NetWare, see Checklists.
  • To find features that have been moved in the Windows Server 2003 family, see New ways to do familiar tasks.
  • For tips about using NWLink or Client Service for NetWare, see Best practices.
  • For help with specific tasks, see How to.
  • For general background information, see Concepts.
  • For problem-solving instructions, see Troubleshooting.

Important

  • XOX XOX
  • XOX
  • XOX


Checklists

This section covers:

  • Checklist: Installing and configuring NWLink
  • Checklist: Installing and configuring Client Service for NetWare


Checklist: Installing and configuring NWLink

Step | Reference
Review concepts. | The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink)
Review hardware requirements. | Hardware requirements for network and dial-up connections
Log on as a user in the Administrators group.
Install NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink).

Note

  • NWLink is installed for all network connections.
 To install NWLink
Set the frame type.

Note

  • This step is for advanced users. New users should accept the default values unless told otherwise by their administrator.
 To configure NWLink
Set the external network number and internal network number.

Note

  • This step is for advanced users. New users should accept the default values unless told otherwise by their administrator.
 To configure NWLink


Checklist: Installing and configuring Client Service for NetWare

Step | Reference
Review concepts. | Client Service for NetWare
Log on as a user in the Administrators group.
Review hardware requirements. | Hardware requirements for network and dial-up connections
Install Client Service for NetWare.

Note

  • The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) is installed when you install Client Service for NetWare.
 To install Client Service for NetWare
Set the default tree and context, or, if you do not use Novell Directory Services (NDS), set the preferred server. To set a preferred server;
To set a default tree and context
Set print options. | To set print options
On the computer running Windows, remove any other existing network service or client software. | Novell or other product documentation
Change the NetWare passwords. | To change your NetWare password
Set logon script options. | Using logon scripts


New ways to do familiar tasks

The following table lists common tasks for interoperating with Novell NetWare in Windows. The user interface for performing these tasks is different in this version of Windows from the way it was in Windows NT version 4.0.

Note

  • XOX
If you want to | In Windows NT 4.0 use | In this version of Windows use
Install and configure the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) | Network in Control Panel | Network Connections. For more information, see To install NWLink and To configure NWLink.
Install Client Service for NetWare | Network in Control Panel | Network Connections. For more information, see To install Client Service for NetWare.
Enable or disable NWLink NetBIOS | Network in Control Panel | Network Connections. For more information, see To enable direct hosting of IPX.


Best practices

This section covers:

  • Best practices for NWLink
  • Best practices for Client Service for NetWare


Best practices for NWLink

If you do not know what value to use for the internal network number, accept the default value of 00000000.

  • You can determine what internal network number your routers are using by typing ipxroute config at a command prompt.
  • For more information about setting the internal network number, see To configure NWLink.

Use automatic frame type detection.

  • You should choose to have the frame type automatically detected rather than setting this value manually. If you must use manual frame type detection, determine what type of frame type you should use before you start configuring the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) by typing ipxroute config at a command prompt. In addition, verify that all the server computers on your network that use IPX/SPX are using the same frame type.
  • For more information, see To configure NWLink.

Specify the order that Windows accesses network providers and protocols.

  • By changing your provider order, and by changing the order of protocols bound to those providers, you can improve performance. For example, if your LAN connection is enabled to access NetWare and Microsoft Windows networks and uses TCP/IP and IPX, but your primary connection is to a NetWare network, you can move NetWare or Compatible Network to the top of the Network providers list on the Provider Order tab, and move NWLink IPX/SPX/NetBIOS Compatible Transport Protocol to the top of the File and Printer Sharing for Microsoft Networks binding on the Adapters and Bindings tab.
  • For more information about modifying the order of network providers, see To modify the network provider order. For more information about modifying protocol bindings, see To modify the protocol bindings order.

Only install and enable the network protocols that you need.

  • Limiting the number of protocols on your computer enhances network performance and reduces network traffic.
  • If Windows encounters a problem with network connectivity, it attempts to establish connectivity by using every network protocol that is installed. By only installing and enabling the protocols that your system can use, Windows does not attempt to connect with protocols it cannot use, and returns status information to you more efficiently.

When using direct hosting, if you cannot access a server computer running Windows 95 or Windows 98 from a server running Windows Server 2003, you must enable NetBIOS over IPX/SPX on the computer running Windows 95 or Windows 98.

  • For more information about enabling NetBIOS, see the Windows 95 or Windows 98 documentation.

When you use NWLink to connect computers running Windows that use Windows-based networking, ensure that NetBIOS broadcast propagation (type 20 packets) is enabled on all the router interfaces that connect the computers running Windows.

  • You can enable NetBIOS broadcast propagation by using Routing and Remote Access. NetBIOS broadcast propagation is enabled by default.


Best practices for Client Service for NetWare

When running Novell Directory Services (NDS) administrative utilities on Windows, you must use NetWare client software.

  • To administer a Novell NDS server from a Windows computer using NDS utilities, you need to run the client software from Novell, not Client Service for NetWare.

When changing a user's NetWare password, synchronize the password for both NetWare and Windows resources.

  • You can use the Change Password dialog box that is available by pressing CTRL+ALT+DELETE. User names and passwords should be the same for all NetWare servers.

When connecting to NetWare resources on NDS trees, confirm that you are using the proper default tree and context.

  • For more information, see To set a default tree and context.

Use the 32-bit version of command prompt.

  • If you are running Client Service for NetWare and use a command prompt, you should use the 32-bit version (that is, Cmd.exe), which is available on the Programs menu, not the 16-bit version (that is, Command.com).

Follow the best practices for NWLink.

  • For more information about the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink), see Best practices for NWLink.


How to...

  • Install and configure Client Service for NetWare
  • Install and configure NWLink
  • Use NetWare resources


Concepts

This section covers:

  • Novell NetWare integration overview
  • The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink)
  • Client Service for NetWare


Novell NetWare integration overview

The Microsoft® Windows® Server 2003 family and XOX provide several services that enable computers running Windows to coexist and interoperate with Novell NetWare networks and servers. Some of these services are included with the Windows Server 2003 family and XOX. Other services are available as separate products.

  • NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink)

    • Included with both Windows Server 2003 family operating systems and XOX, NWLink is the Windows implementation of the IPX/SPX protocol. NWLink supports connectivity between computers running Windows and computers running NetWare and compatible systems. You can also use NWLink as a protocol that connects Windows-based computers and computers running MS Client for DOS. For more information about NWLink, see The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink).

  • Client Service for NetWare

    • Included with the Windows Server 2003 family and XOX, Client Service for NetWare makes direct connections from workstations to file and printer resources on NetWare servers. With Client Service for NetWare, you can access servers running either Novell Directory Services (NDS) or bindery security. Logon script support is also included.

  • Microsoft Directory Synchronization Services

    • Included with Services for NetWare (a separate product), Microsoft Directory Synchronization Services (MSDSS) can perform a one-time migration of directory objects or synchronize directory objects from both Novell Directory Services (NDS) and Bindery environments with Microsoft Active Directory.


The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol

Microsoft Windows graphic

The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink)

This section covers:

  • NWLink overview
  • Understanding NWLink
  • Using NWLink


NWLink overview

NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) is an implementation of Novell's Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX) and NetBIOS protocols. Windows clients can use NWLink to access client and server applications running on Novell NetWare servers. NetWare clients can use NWLink to access client and server applications running on Windows servers. With NWLink, computers running Windows can communicate with other network devices, such as printers, that use IPX/SPX. You can also use NWLink in small networks that only use Windows and other Microsoft client software.


Understanding NWLink

The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) is a Network Driver Interface Specification (NDIS)-compliant, native 32-bit implementation of Novell's IPX/SPX protocol. NWLink supports two networking application programming interfaces (APIs): NetBIOS and Windows Sockets. These APIs allow communication among computers running Windows and between computers running Windows and NetWare servers.

The NWLink transport driver is an implementation of the lower-level NetWare protocols, which include IPX, SPX, RIPX (Routing Information Protocol over IPX), and NBIPX (NetBIOS over IPX). IPX controls addressing and routing of packets of data within and between networks. SPX provides reliable delivery through sequencing and acknowledgments. NWLink provides NetBIOS compatibility with a NetBIOS layer over IPX.

Interoperating with NetWare resources

Depending on what platform you are using and what resources that you want to access, you may need to use NWLink in conjunction with other tools. The following table lists several interoperability options that use NWLink.

Platform | Running | Can connect to
Windows | NWLink | Client/server applications running on a NetWare server
Windows | NWLink and Client Service for NetWare | NetWare servers for file and print services
NetWare client | IPX with NetBIOS, Named Pipes, or Windows Sockets support | Computers running Windows (with NWLink installed) running IPX applications such as Microsoft SQL Server
NetWare client | IPX | Servers running Windows Server 2003 (with NWLink installed) for file and print services

For a Windows client to access file and print resources on a NetWare server, Client Service for NetWare must be installed on the Windows client in addition to NWLink. For more information, see Novell NetWare integration overview.

Interoperating with Microsoft resources

By default, the file and print sharing components of Windows use NetBIOS over IPX to send file and print sharing messages.

Alternatively, you can disable NetBIOS so that the file and print sharing messages are sent directly over IPX. This is known as direct hosting. While direct hosting may be more efficient, it causes an interoperability issue: A direct hosting client can only connect to a direct hosting server. Direct hosting clients include computers running Microsoft Network Client for MS-DOS, Windows for Workgroups, Windows 95, and Windows 98. Direct hosting servers include computers running Microsoft Network Client for MS-DOS, and all Windows-based computers.

The following table lists several interoperability options that use IPX.

Platform | Running | Can connect to
Microsoft Network Client for MS-DOS Windows for Workgroups Windows 95 Windows 98 | IPX only (direct hosting) | File and print shared resources on computers running: Microsoft Network Client for MS-DOS Windows for Workgroups Windows 95 Windows 98 Windows NT Windows 2000 Windows
Microsoft Network Client for MS-DOS Windows for Workgroups Windows 95 Windows 98 Windows NT Windows 2000 Windows | NetBIOS over IPX | File and print shared resources on computers running: Microsoft Network Client for MS-DOS Windows for Workgroups Windows 95 Windows 98 Windows NT Windows 2000 Windows

Important

  • You cannot use direct hosting of IPX to gain access to resources on any computer acting as a direct host server from a computer running Windows. Computers running Windows do not include a direct hosting client for NWlink. For example, while you can connect by using direct hosting of IPX to resources on a computer running Windows from a computer running Windows 95 or Windows 98 (where NetBIOS is disabled by default for performance reasons), you cannot connect by using direct hosting of IPX to the computer running Windows 95 or Windows 98 from the computer running Windows. For detailed instructions about enabling direct hosting, see To enable direct hosting of IPX.


Using NWLink

This section covers:

  • Installing NWLink
  • Configuring NWLink
  • Routing and NWLink


Installing NWLink

You can install the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) when you install a Windows Server 2003 family operating system, or you can install NWLink later. You must be logged on as a member of the Administrators group to install and configure NWLink. For more information about installing NWLink, see Checklist: Installing and configuring NWLink.


Configuring NWLink

This section covers:

  • Setting the frame type
  • Setting the external and internal network numbers


Setting the frame type

The frame type defines the way in which the network adapter, in a computer running Windows, formats data to be sent over a network. To communicate between a computer running Windows and NetWare servers, you need to configure the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) on the computer running Windows with the same frame type as the one used by the NetWare servers.

The following table lists the topologies and frame types supported by NWLink.

Topology | Supported frame type
Ethernet | Ethernet II, 802.3, 802.2, and Sub Network Access Protocol (SNAP), which defaults to 802.2
Token ring | 802.5 and SNAP
Fiber Distributed Data Interface (FDDI) | 802.2 and 802.3

Note

  • On Ethernet networks, the standard frame type for NetWare 2.2 and NetWare 3.11 is 802.3. Starting with NetWare 3.12, the default frame type was changed to 802.2.

You can choose to automatically detect or manually configure the frame type. However, the frame type is automatically detected when NWLink is loaded. If multiple frame types are detected in addition to the 802.2 frame type, NWLink defaults to the 802.2 frame type.

If the frame type is manually configured, a computer running Windows can use multiple frame types simultaneously.

For more information about configuring the frame type, see To configure NWLink.


Setting the external and internal network numbers

The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) uses two types of IPX network numbers for routing purposes: external network numbers, referred to as the Network number in the Manual Frame Detection dialog box, and internal network numbers, referred to as the Internal network number in the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol Properties dialog box. Both are hexadecimal numbers, with 1 to 8 digits (1 to FFFFFFFE).

The external network number is associated with physical network adapters and networks. To communicate with each other, all computers on the same network that use a given frame type must have the same external network number. If your computer has multiple network adapters that are connected to different networks, you must assign an external network number to each configured frame type and network adapter combination on your computer. If you do not know the appropriate numbers to use, see your NetWare documentation. If you do not set an external network number, the number is automatically detected by the Windows operating system.

The internal network number, also called a virtual network number, identifies a virtual network inside a computer. On a server computer running Windows, programs advertise themselves as being located on the virtual network, not a physical network. When you assign internal network numbers, you gain more efficient routing to the programs in a computer with multiple network adapters that are connected to multiple, interconnected networks. By default, the internal network number is 00000000. However, in each of the following situations, you need to manually assign a unique, nonzero internal network number:

  • Your computer is acting as a server (running Windows) for a program that uses the NetWare Service Advertising Protocol (SAP), such as SQL Server or SNA Server.
  • Your computer is acting as an IPX router that uses the Windows routing.

For more information about setting the external and internal network numbers, see To configure NWLink.


Routing and NWLink

This section covers:

  • Using the Routing Information Protocol
  • Using the Service Advertising Protocol
  • Using Ipxroute


Using the Routing Information Protocol

In networks that use only the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink), routing information is propagated by using the Routing Information Protocol (RIP). NWLink uses the Routing Information Protocol over IPX (RIPX) to determine the best router to use when forwarding IPX traffic to another IPX network.

RIPX and NWLink

RIPX is used to determine the frame type and external network number for each interface that is configured for autodetection. When NWLink loads, it sends out a RIPX request to discover the frame type and external network number. IPX routers (and NetWare servers) respond to the request with packets that use the IPX router frame type and contain the external network number of the local network.

RIPX and routers

When the IPX host determines the IPX network number of the destination, it compares the destination IPX network number with its own attached external network number. If they are different, the IPX host must forward the IPX packet to an IPX router. To determine the best router to use to forward the IPX traffic, the IPX host sends out a RIP request for the destination IPX network number. All IPX routers on the network of the IPX host that have a route to the destination network number send back a response to the IPX host. The IPX host chooses the best response and forwards the IPX packet to the router that sent the best response.

When the Windows Routing and Remote Access service is installed, the computer running Windows acts as a RIP-based IPX router. RIPX is used to listen for route announcements and periodically send route announcements to maintain an IPX routing table.

For more information about routing with Windows, see Checklist: Installing and configuring the router.


Using the Service Advertising Protocol

The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) uses the Service Advertising Protocol (SAP) to locate the nearest server upon startup and to locate either all services or all services of a specific type. When the Windows Routing and Remote Access service is installed, the computer running Windows also uses SAP to listen for SAP advertisements and periodically make SAP advertisements to maintain a table of available services on the network. If you have installed Routing and Remote Access, you can run just SAP advertising and routing by disabling all other functions of the Routing and Remote Access.

The SAP Agent is a network service that allows services on a server running Windows Server 2003 to advertise themselves by using periodic SAP advertisements. Without the SAP Agent, the services on a computer running Windows are unavailable to computers running NetWare client software as well as computers running Windows that are configured to use just the NWLink protocol.

You can manually install the SAP Agent by using the properties of a connection, but is usually automatically installed when a service that uses the SAP Agent is installed. An example is Microsoft Exchange Server. To make the computer running Microsoft Exchange Server available to computers running NetWare client software and computers running Windows that are configured to use just the NWLink protocol, the Microsoft Exchange Server setup program automatically installs the SAP Agent. Once installed, the Microsoft Exchange Server service uses the SAP Agent to periodically advertise its presence and location so that it can be contacted by Microsoft Exchange clients on an IPX network.

When Routing and Remote Access is running, you can configure SAP settings per network adapter, such as whether to forward broadcasts from one adapter to another or whether to disable SAP over an adapter. These settings are configured through the Routing and Remote Access console. You cannot configure the SAP Agent.

The following table summarizes the relationship between the SAP Agent and Routing and Remote Access.

Status of Routing and Remote Access/SAP Agent | Routing method
Neither SAP Agent nor Routing and Remote Access is running | Services are not advertised/routed.
SAP Agent is running (but not Routing and Remote Access) | SAP Agent advertises/routes services.
Routing and Remote Access is running (but not SAP Agent) | Routing and Remote Access advertises/routes services.
Both SAP Agent and Routing and Remote Access are running | Routing and Remote Access advertises/routes services.

Note

  • You do not need to install the SAP Agent service separately when Routing and Remote Access is running, since Routing and Remote Access assumes the responsibilities of the SAP Agent.


Using Ipxroute

You can modify the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) settings that affect routing with the Ipxroute.exe command-line utility (the ipxroute command). The Ipxroute utility provides the same functionality as the Route.exe command-line utility that is supplied by Novell for its MS-DOS-based clients.

The Ipxroute utility manages the source routing variables of NWLink. Ipxroute.exe is installed only if the NWLink transport protocol is bound to a network adapter.

The Ipxroute utility changes these settings for the current session only. When you log off, the settings are lost. To permanently change NWLink settings, you must set them in the registry.

For information about the ipxroute command, see Ipxroute.


Client Service for NetWare

This section covers:

  • Client Service for NetWare overview
  • Using Client Service for NetWare


Client Service for NetWare overview

A user who works locally on a computer running Windows can use Client Service for NetWare to gain direct access to NetWare file and print resources, both on Novell Directory Services (NDS) trees and on servers with bindery security.

Client Service for NetWare depends on and works with the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink). NWLink is an implementation of the Internetwork Packet Exchange (IPX), Sequenced Packet Exchange (SPX), and NetBIOS transport protocols used by the NetWare network. The Microsoft implementations of these protocols can coexist seamlessly with other protocols on the same network adapter.

Note

  • Client Service for NetWare does not support the IP protocol and therefore cannot be used to interoperate with NetWare 5.x in an IP-only environment. To do this, you must load the IPX protocol onto the NetWare 5.x server, or use a redirector that is compatible with NCP and supports native IP.


Using Client Service for NetWare

This section covers:

  • Installing Client Service for NetWare
  • Configuring Client Service for NetWare
  • Connecting directly to NetWare resources


Installing Client Service for NetWare

You have the option to install Client Service for NetWare when you install a Windows Server 2003 operating system, or you can install Client Service for NetWare later. You must be logged on as a member of the Administrators group to install and configure Client Service for NetWare. For more information about installing Client Service for NetWare after you have already installed a Windows Server 2003 operating system, see To install Client Service for NetWare.

During installation of Client Service for NetWare, the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) is installed if it is not already on the server. For more information about NWLink, see The NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink).

By default, the NetWare network is placed first in the network search order.

Important

  • XOX XOX
  • Before you install Client Service for NetWare on a computer, remove any existing client software that is compatible with NCP, including NetWare client software, from the computer.


Configuring Client Service for NetWare

When you first log on after Client Service for NetWare is installed, you are prompted to set your default tree and context or your preferred server. The tree and context define the position of the user object for the user name you use to log on to a Novell Directory Services (NDS) tree. A preferred server is the NetWare server to which you are automatically connected when you log on, if your network does not use NDS.

You can have either a default tree and context or a preferred server, but not both. (In NDS environments, you set a default tree and context.) If you select a default tree and context, you can still access NetWare servers that use bindery security.

For more information, see To set a preferred server and To set a default tree and context. To change your tree and context at a later time, you can use Client Service for NetWare (in Control Panel).


Connecting directly to NetWare resources

Novell Directory Services (NDS) trees (as well as NetWare servers running bindery security) appear under NetWare or Compatible Network in Windows Explorer. You can double-click a tree name to expand it, and then double-click any container object to expand its contents and structure. You can connect to and assign a local drive to any volume, folder, or directory map object anywhere in the tree hierarchy (for which you have credentials). For more information, see To connect to a NetWare resource.

To connect to an NDS printer, you can use the Add Printer wizard, just as you would to connect to any network printer. For more information, see To connect to a printer attached to a NetWare server.

If you have a default tree and context, once you have logged on, you do not need to log on again or supply another password to access any volume in your default tree. If you access another tree, you are prompted to supply a full context (including user name) for that tree.

This section covers:

  • Changing the NetWare password
  • Using logon scripts
  • Managing NetWare file attributes
  • Running NetWare utilities and programs that can use NetWare


Changing the NetWare password

Users who use Client Service for NetWare to directly access NetWare resources can change their passwords on NDS trees on the network. For more information, see To change your NetWare password.


Using logon scripts

When a user, running Client Service for NetWare to directly access NetWare resources, first makes a connection to a particular NetWare server, the user's logon script (if any) runs.

Note

  • If you are running Client Service for NetWare and use a command prompt, you should use the 32-bit version (Cmd.exe), which is available on the Programs menu, not the 16-bit version (Command.com). While running Client Service for NetWare, if you run a batch file (such as a logon script) that opens an instance of the command prompt, the batch file should begin with the command #cmd, not #command.


Managing NetWare file attributes

When you use a computer running Client Service for NetWare to directly access NetWare servers, you can use NetWare utilities (such as the filer and rights commands), to set attributes that are not supported by the mapping of Windows–to–NetWare file rights. For more information about other supported utilities, see Running NetWare utilities and programs that can use NetWare.


Running NetWare utilities and programs that can use NetWare

On servers running Windows Server 2003 and Client Service for NetWare, you can run some standard NetWare utilities from a command prompt and many programs that can use NetWare. Client Service for NetWare does not support NetWare 4.x or 5.x utilities. In addition, for some administrative functions, you must use the management tools included with your Windows Server 2003 family operating system.


Troubleshooting

What problem are you having?

Client Service for NetWare does not start.

Cause: One of the required services or protocols might be unavailable.

Solution: Try to start Client Service for NetWare manually. If that fails, use Event Viewer to look at the system log and troubleshoot the problem.

See also: Event Viewer

Client Service for NetWare starts, but no servers are found.

Cause: The frame type or SAP might be configured incorrectly.

Solution: Try the following:

  • View the network adapter load line in the Autoexec.ncf file of the NetWare server to verify that you are using the correct frame type for the server. For example, suppose a network adapter load line for a server is:

    load 3C503 FRAME=ETHERNET_802.3 NAME=ETH

    In this case, the server is bound to a 3Com 503 Ethernet adapter that accepts the raw 802.3 frame format.

    To see the frame type that is set for your network adapter, start Network Connections in Control Panel. If the frame type is detected automatically and the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) detects any frames of type 802.2 or no frames at all, NWLink sets the frame type to 802.2. If the network adapter receives frames of type 802.2, but your NetWare network uses a different frame type, you must set the frame type manually.

    To determine which frame type your routers are using on a server running Windows Server 2003, at a command prompt, type:

    ipxroute config

  • If you cannot see NetWare file server resources, ensure that SAP is enabled on all the router interfaces that connect the computers running Windows and the server computers running NetWare software. (A Windows remote access server, which is a server running Windows Server 2003 and the Routing and Remote Access service, is an IPX router.) You can enable SAP on an interface by using Routing and Remote Access.

See also: To configure NWLink

Client Service for NetWare starts, but only some resources are found.

Cause: The tree and context or SAP might be configured incorrectly.

Solution: Try the following:

  • In an Novell Directory Services (NDS) environment, verify that you are using the correct tree and context.

  • For each IPX router, view the SAP service table and verify that all of the services that should be learned from SAP are present. If some of the services are not present, you should verify that SAP filtering is not preventing the propagation of these services. The SAP service table is not the same as running the NetWare slist command or running an NDS query for a list of all the servers in the tree.

See also: To view routing tables

Cannot use the NetWare map command to connect to file or print resources.

Cause: You might be using the wrong command prompt, or the default environment size of the command prompt window might be too small.

Solution: The default environment for 16-bit programs is too small to accommodate the mapping table created by the map command. Designate the 32-bit command prompt (that is, Cmd.exe) as the permanent command interpreter, and reset the default environment size allocated to the command prompt window. An environment of 4,096 bytes is large enough to accommodate the map command, the mapping table, and the command interpreter.

To make these changes to the environment, type the following line in Config.nt:

shell=%systemroot%\system32\cmd.exe /e:4096

This line sets Cmd.exe as the command interpreter for the window as long as it remains open or until you run another shell command. The line also permanently allocates 4,096 bytes of environment space to 16-bit programs you run in the window.

The network does not start when you start your computer.

Cause: You might have duplicate computer names.

Solution: You must specify a computer name that is not the same as the name of another computer on the network or the same as the name of a workgroup or a domain on the network.

A computer running the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (NWLink) cannot connect to other computers.

Cause: Routing might be configured incorrectly.

Solution: Try the following:

  • Verify that you have NetBIOS broadcast propagation (type 20 packets) enabled on all the router interfaces between the computers. (A Windows remote access server, which is a server running Windows Server 2003 and the Routing and Remote Access service, is an IPX router.) You can enable NetBIOS broadcast propagation in Routing and Remote Access.
  • Verify that you do not have more than eight routers between the computers running Windows.