Compile Date

 Compile Date: 2003-01-04


Extensible Firmware Interface

The Extensible Firmware Interface (EFI) is a new type of interface between a computer's firmware, hardware, and the operating system. Computers with the Intel Itanium family of processors use EFI to start and load XOX, the 64-bit version of XOX, and the 64-bit version of XOX. EFI serves the same purpose for Itanium-based computers as the BIOS found in x86-based computers, but has expanded capabilities that provide:

  • A consistent way to start any compatible operating system.
  • An easy way to add EFI drivers for new bootable devices without the need to update the computer's firmware.

With EFI, an Itanium-based computer can have hard disks with the GUID partition table (GPT) partitioning style and the master boot record (MBR) partitioning style. However, in order for EFI to start and load XOX, the 64-bit version of XOX, or the 64-bit version of XOX, the operating system must reside on a GPT disk. In a mixed GPT and MBR disk environment, MBR disks are used solely for data storage.

Every Itanium-based computer must have one GPT disk with an EFI System partition. Like the system volume on x86-based computers, the EFI System partition contains the operating system loader, drivers, and other files required to start XOX, the 64-bit version of XOX, or the 64-bit version of XOX. In computers that contain only one GPT disk, the EFI System partition is the first partition on the disk.

The EFI System partition is formatted as FAT and contains an EFI directory at the root directory. XOX, the 64-bit version of XOX, and the 64-bit version of XOX, create a subdirectory called \EFI\Microsoft\Winnt50. Other subdirectories created by operating system vendors, original equipment manufacturers (OEMs), BIOS vendors, and other tools vendors might also be present. The \Msutil subdirectory contains utilities that are used by the EFI firmware and operating system. These utilities as well as the contents of the EFI System partition, can be accessed using the EFI firmware's Boot Manager. The contents of the \EFI\Microsoft\Winnt50 subdirectory should be accessed only by authorized support technicians.

Caution

  • When you update the software in the EFI System partition, apply only authentic updates provided by your OEM or other trusted source. Applying other updates might introduce a virus, Trojan horse, or other malicious code that might make your computer inoperable.

For more information about GPT, see GUID partition table (GPT), or "Disk Management" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/). For more information about EFI, see the manufacturer's documentation that came with your computer, or the Intel Web site.

XOX


GUID partition table

Instead of a BIOS, computers with the Intel Itanium family of processors use the Extensible Firmware Interface (EFI) between the computer's firmware, hardware, and the operating system. EFI includes a new disk partitioning style, the GUID partition table (GPT).

Compared to the master boot record (MBR) disk partitioning style, which supports volumes up to 2 terabytes in size and up to 4 primary partitions per disk (or three primary partitions, one extended partition, and unlimited logical drives), GPT supports volumes up to 18 exabytes in size and up to 128 partitions per disk (in XOX, the 64-bit version of XOX, or the 64-bit version of XOX). Unlike MBR partitioned disks, data critical to platform operation is located in partitions instead of unpartitioned or hidden sectors. In addition, GPT partitioned disks have redundant primary and backup partition tables for improved partition data structure integrity.

Disk Management describes disks with the GUID partition table (GPT) partitioning style as GPT disks and disks with the master boot record (MBR) partitioning style as MBR disks. You can perform the same tasks on GPT disks as you can on MBR disks with the following exceptions:

  • GPT disks are supported only by the XOX, the 64-bit version of XOX, and the 64-bit version of XOX. You cannot move GPT disks to computers running the 32-bit versions of XOX or the Windows Server 2003 family of operating systems. From Disk Management on computers running a 32-bit version of XOX or the Windows Server 2003 family of operating systems, GPT disks appear as basic MBR disks with a single partition covering the whole disk, but the data on the partition cannot be accessed.
  • The operating system loader and boot partition must reside on a GPT disk. Other hard disks can be either MBR or GPT.
  • You can have both MBR and GPT disks in a single dynamic disk group. You can also have a mix of basic GPT and MBR disks, which are not part of disk groups. You can create mirrored, striped, spanned and RAID-5 volumes using a combination of MBR and GPT disks, but the MBR cylinder alignment restriction may cause some difficulties in creating mirrored volumes. Always mirror the MBR disk to the GPT disk to avoid cylinder alignment difficulties.
  • You can convert an MBR disk to a GPT disk and vice versa only if the disk is empty.
  • Mirroring the EFI System partition is not supported.
  • You cannot use the GPT partitioning style on removable media, detachable disks that use universal serial bus (USB) or IEEE 1394 (also called FireWire) interfaces, or on cluster disks that are connected to shared SCSI or Fibre channel buses used by Cluster service.

You can create partitions on basic GPT disks using the EFI firmware utility diskpart.efi, the diskpart.exe command-line utility, or Disk Management in XOX, the 64-bit version of XOX, or the 64-bit version of XOX.

In a system recovery scenario, see the manufacturer's documentation that came with your computer for recreating or restoring a GPT disk.

For more information about DiskPart.exe, see DiskPart. For more information about the Disk Management snap-in, see Disk Management overview. For more information about diskpart.efi, see the Intel Web site.

For more information about managing GPT and MBR disks, see Extensible Firmware Interface (EFI) or "Disk Management" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/).

XOX