File Server Management Overview

File Server Management Overview

File Server Management provides a centralized tool for managing your file server. A file server provides a central location on your network where you can store and share files with users across your network.

Using File Server Management, you can perform many file server management tasks, such as formatting volumes, creating shares, defragmenting volumes, creating and managing shares, setting quota limits, creating storage utilization reports, replicating data to and from the file server, managing Storage Area Networks (SANs), and sharing files with UNIX and Macintosh systems.

The tasks you can perform depend on the features selected when you installed the file server role. For information about how to install the file server role or to add optional features, see File server role: Configuring a file server in the Configure Your Server online Help (CYS.chm).

The following features are typically loaded with File Server Management:

Share Folder Management

Share Folder Management includes:

  • Shared Folders

    Shared Folders enables you to manage shared resources over a network. With Shared Folders, you can:

    • Control user access permissions, session activity, and shared resource properties.

    • Create, view, and set permissions for shared resources.

    • View a summary of connections and resource use for local and remote computers.

    • View a list of all users who are connected over a network to the computer and disconnect one or all of them.

    • View a list of files that are opened by remote users and close one or all of the open files.

Disk and Volume Management

Disk and Volume Management includes:

  • Disk Defragmenter

    Disk Defragmenter analyzes local volumes and consolidates, or defragments, fragmented files and folders so that each occupies a single, contiguous space on the volume. As a result, your system can access files and folders and save new ones more efficiently. By consolidating your files and folders, Disk Defragmenter also consolidates a volume's free space, making it less likely that new files will be fragmented. The process of consolidating fragmented files and folders is called defragmentation. Disk Defragmenter can defragment volumes that are formatted with the file allocation table (FAT) file system, the FAT32 file system, and the NTFS file system.

  • Disk Management

    Disk Management is a system utility for managing hard disks and the volumes or partitions that they contain. With Disk Management, you can initialize disks, create volumes, format volumes with the FAT, FAT32, or NTFS file systems, and create fault-tolerant disk systems. Disk Management enables you to perform most disk-related tasks without restarting the system or interrupting users; most configuration changes take effect immediately.

File Server Resource Manager

File Server Resource Manager includes:

  • Quota Management

    Quota management allows you to create quotas to limit the space allowed for a volume or folder and generate notifications when the quota limits are approached or exceeded. You can also define quota templates that can be easily applied to new volumes or folders and that can be used across an organization and auto apply quota templates to all existing folders in a volume or folder, as well as to any new subfolders created in the future.

  • File Screening Management

    With File Screening Management you can create file screens to control the types of files that users can save and to send notifications when users attempt to save blocked files, define file screening templates that can be easily applied to new volumes or folders and that can be used across an organization, and create file screening exceptions that extend the flexibility of the file screening rules.

  • Storage Reports Management

    Storage Reports Management enables you to schedule periodic reports that help you to identify trends in disk usage. You can also monitor attempts to save unauthorized files for all users or a selected group of users.

DFS Management

DFS Management includes:

  • DFS Management snap-in

    You can use the DFS Management snap-in to configure and manage the two technologies in the Distributed File System solution: DFS Namespaces and DFS Replication. Together, you can use these technologies to collect and distribute data and for loose collaboration.

  • DFS Namespaces

    You can create a namespace to group shared folders located on different servers and present them to users as a virtual tree of folders. A namespace provides numerous benefits, including increased availability of data, load sharing, and simplified data migration. When browsing the namespace, users see a single folder and are not aware the folder is hosted by multiple servers. When a user opens the folder, the client computer is automatically referred to a server in its own site; if no same-site servers are available, you can configure the namespace to refer the client to a server that has the lowest connection cost as defined in the Active Directory® directory service.

  • DFS Replication

    DFS Replication is a new multimaster replication engine that is used to keep folders synchronized on multiple servers. Replicating data to multiple servers increases data availability and gives users in remote sites fast, reliable access to files. DFS Replication uses a new compression algorithm known as remote differential compression (RDC). RDC is a “diff over the wire” protocol that can be used to efficiently update files over a limited-bandwidth network. RDC detects insertions, removals, re-arrangements of data in files, enabling DFS Replication to replicate only the deltas (changes) when files are updated.