Emergency Management Services

The Microsoft® Windows® Server 2003 family provides native support for server operation and management that can be performed without a local keyboard, mouse, or monitor. Emergency Management Services is one element of an out-of-band management solution that you can use to manage servers remotely when the operating system is not running properly. Emergency Management Services is available with or without a video card.

  • For recommendations on setting up and using Emergency Management Services most effectively, see Best practices.
  • For help with using Emergency Management Services to solve problems with your system, see How to.
  • For general background information on Emergency Management Services, see Concepts.
  • For help solving problems that might occur in Emergency Management Services, see Troubleshooting.


Best practices

  • Best practices for using in-band tools
  • Best practices for selecting and configuring hardware
  • Best practices for implementing security measures


Best practices for using in-band tools

Try using in-band tools before using Emergency Management Services.

  • If your server becomes unstable, try to use in-band tools before using Emergency Management Services to troubleshoot your operating system.

    This is important because Emergency Management Services is designed to be used only when in-band means of accessing and managing the server are unavailable. For example, you would use Emergency Management Services to force your system to reset only if you are unable to reset it using the standard, in-band tools. In addition, be aware that Emergency Management Services is not a complete management solution; your ability to access and manage the server at all times depends upon your hardware configuration.

    • For more information, see In-band management.

Enable and configure in-band tools during Setup.

  • Because in-band tools can be difficult or impossible to configure remotely after Setup has completed, it is important to enable and configure these tools during Setup. Examples of in-band tools include Terminal Services Remote Desktop for Administration and Telnet.

    • For more information, see In-band management.


Best practices for selecting and configuring hardware

Ensure that the BIOS supports console redirection and the SPCR table.

  • If there is no Serial Port Console Redirection (SPCR) setting, the basic input/output system (BIOS) either enables it automatically or does not support it. It is preferable to have a BIOS that supports the SPCR table. If this is not the case, you must enable and configure Emergency Management Services manually. You can do this during Setup or by using the Bootcfg.exe tools in the operating system. Configure Emergency Management Services to use the same settings as the BIOS console redirection. Be sure to make a note of the baud rate and the serial port that you set.
  • You might find it necessary to enable console redirection in the BIOS settings. COM 1 is the preferred COM port. Make a note of the baud rate and the COM port that you set. You must use this information to attach a serial cable properly to the correct port. You also must use this information to configure your terminal emulator to the correct baud rate.
  • If the SPCR table is supported by the BIOS, it can be enabled automatically when BIOS redirection is enabled. If the BIOS has a setting for SPCR or SPCR table, be sure to configure it.
  • Configure your server to reboot automatically if a Stop error occurs. This allows the server to reboot without requiring you to access !Special Administration Console (!SAC) or the power switch to reboot it manually. This provides maximum availability if a Stop error occurs.

    • For more information, see Firmware console redirection.

Choose the highest baud rate that your hardware and Emergency Management Services allows.

  • This gives you the best performance.
  • This also prevents a slow text-mode Setup process.
  • For the preferred Remote Installation Services (RIS) implementation, use a redirecting BIOS that prompts you to boot from the network and a version of Startrom.com that does not redirect.

    • For more information, see Configuring serial ports.

When using Emergency Management Services with a serial port, use a null modem cable with carrier detect.

Select service processors that support Emergency Management Services.

  • A service processor can provide additional management functionality that complements that of Emergency Management Services. This gives you a more complete remote-management solution.
  • Use an original equipment manufacturer (OEM) service processor that provides, at a minimum, reset and BIOS console redirect capabilities.
  • You must select a service processor that supports Emergency Management Services. In addition, you might find it necessary to enable the service processor so that it provides that support.
  • It might be necessary to update your firmware to enable it to support Emergency Management Services. Service processors can require their own firmware updates in addition to system firmware updates. With the proper firmware updates, your current service processors might support Emergency Management Services.

    • For more information, see Service processors.

Configure your server to reboot automatically if a Stop error occurs.

  • This makes it unnecessary for you to access !SAC or the power switch to reboot the server manually. It also provides maximum availability if a Stop error occurs.

Select hardware and firmware that supports VT-UTF8.

  • If your hardware and firmware do not use the same terminal type that Emergency Management Services uses, it can be extremely difficult to send the proper command escape sequences. This is because the command escape sequences change according to whether the hardware, firmware, or Emergency Management Services is controlling the port.
  • Hardware and firmware that support VT-UTF8 or VT100+ provide the best compatibility. To prevent incompatibility, you must at least select hardware and firmware that support VT100.
  • It might be necessary to update your system and service processor firmware to enable VT-UTF8 or VT100+ output.

    • For more information, see VT-UTF8, VT100+, and VT100 conventions.


Best practices for implementing security measures

Limit the ability of users to access your out-of-band infrastructure.

  • When used incorrectly or maliciously, Emergency Management Services and out-of-band management hardware can be made to disrupt the use of a server. To prevent this problem, limit physical access to the server. This will also keep unwanted users from accessing Emergency Management Services through a serial port. To provide this level of physical security, be sure to protect sensitive areas such as racks, computer labs, server farms, and data centers by locking them.
  • Use a terminal concentrator with security features. If you access your servers out-of-band through a terminal concentrator, choose one that provides security when you connect through the network.
  • Select service processors with well-designed security implementations. Service processors can provide improved access mechanisms, such as network interfaces. With these improvements, however, come the added security risks of network access. You must ensure that any service processor you enable provides a secure access mechanism.
  • Consider setting up a separate network dedicated exclusively to management traffic, including that of Emergency Management Services. A separate network for management traffic adds an additional layer of security. Only known, secure management workstations should be granted access to this network and its out-of-band server connections. The management network must not allow any connections to the Internet, and it must authenticate only trusted users.

    • For more information, see Remotely administered servers, Service processors, and Terminal concentrators.


How to...

  • Verify that Emergency Management Services is enabled
  • Start the computer
  • View the POST status and errors
  • View and manage the system while the loader and kernel initialize
  • View and manage the system during text-mode Setup
  • Determine the cause of a pause or failure during GUI-mode setup
  • Resolve system resource problems using SAC
  • Respond to a Stop error message
  • Respond if SAC and !SAC become unavailable
  • Change channels


Verify that Emergency Management Services is enabled

Microsoft Windows Graphic

To verify that Emergency Management Services is enabled

You can use Bootcfg to quickly verify that Emergency Management Services is active in an x86-based or Itanium based system without connecting devices to the out-of-band port.

  • At a command prompt, type:

    bootcfg/query

Note

  • You can also check the registry to verify Emergency Management Services installation. For more information on working with the registry, see "Resources" in Related Topics.

Related Topics


Start the computer

Microsoft Windows Graphic

To start the computer

Depending on the remote computer's hardware configuration, you can use one or more of the following approaches to start your computer. For more information, see your hardware manufacturer's documentation.

  • Use the interface supplied by a service processor, if one is present, to turn on the remote computer.
  • Use the interface supplied by a power switch or uninterruptible power supply (UPS) with remote computer management capabilities, if one is present, to turn on the computer.
  • Use wake-on-LAN functionality by sending a network request that "wakes" the remote computer from sleep mode. This feature must be supported by both the system motherboard and firmware. Follow the instructions provided by your computer and network adapter motherboard manufacturers to enable this functionality.
  • If none of these approaches is appropriate, you can go to the physical location of the target computer and start it by pressing the power button.

Note

  • For general background information on wake-on-LAN functionality, see "Routing and Remote Access" in Related Topics.

Related Topics


View the POST status and errors

Microsoft Windows Graphic

To view the POST status and errors

Depending on the remote computer's hardware configuration, one or more of the following approaches can help the computer complete the power-on self test (POST).

For all of these options, you must configure the remote computer's firmware or service processor, if one is present, to redirect the POST. You will then be able to view the progress of the POST. For more information, see to your hardware manufacturer's documentation.

  • Connect to the remote computer's service processor, if one is present, and restart the computer.
  • If a service processor is present, and the out-of-band tools are available, perform diagnostic procedures using the service processor's out-of-band tools.
  • Use a power switch or uninterruptible power supply (UPS) with remote computer management capabilities, if one is present, to restart the remote computer.

Note

  • Windows Server 2003 operating systems cannot start if the remote computer stops responding before completing the POST.

Related Topics


View and manage the system while the loader and kernel initialize

Microsoft Windows Graphic

To view and manage the system while the loader and kernel initialize

  • Ensure that Emergency Management Services is enabled on the remote computer.
  • If the remote computer's operating system fails to initialize, note whether an error message appears. If you do not receive an error message, use the D command in either Special Administration Console (SAC) or !Special Administration Console (!SAC) to view the log.
  • Restart the remote computer using SAC or !SAC and correct the problem.

Notes

  • You can use both firmware console redirection and Emergency Management Services console redirection to monitor the remote system's startup as if you were at a local console. It is preferred that the remote computer's firmware be able to pass the configuration settings of the out-of-band port to the operating system using the Serial Port Console Redirection (SPCR) table. If your system uses Extensible Firmware Interface (EFI), Windows reads the boot settings from the SPCR table. If your system does not use EFI, Windows reads the boot settings from the boot.ini file.
  • For more information, see "Verifying that Emergency Management Services is configured" in Related Topics.
  • For more information about how to restart the remote computer, see "Startup options" in Related Topics.

Related Topics


View and manage the system during text-mode Setup

Microsoft Windows Graphic

To view and manage the system during text-mode Setup

Depending on the remote computer's hardware configuration, one or more of the following approaches can help you view and manage the system during text-mode Setup. If the remote computer has a serial port console redirection (SPCR) table, Emergency Management Services will automatically display the pertinent information. For more information, see your hardware manufacturer's documentation.

  • For x86-based systems, use Remote Installation Services (RIS) to install Windows Server 2003 operating systems.
  • If you are not using unattended Setup files, you must choose Express Setup when prompted.
  • If Setup fails, note any error messages that appear and attempt to correct any problems you discover.

Notes

  • When you are using GUI-mode Setup, you must perform an unattended Setup. This allows GUI-mode Setup to proceed without prompting you for input. If you do not perform an unattended Setup, GUI-mode Setup will fail.
  • You can use RIS-based installations to perform unattended Setups. When you RIS-based installations for this purpose, it is not necessary to use the operating system CD or a floppy disk containing a Winnt.sif file. For more information on RIS and the Winnt.sif file, see Related Topics.

Related Topics


Determine the cause of a pause or failure during GUI-mode Setup

Microsoft Windows Graphic

To determine the cause of a pause or failure during GUI-mode Setup

  • To determine the reason for a pause or failure during a GUI-mode Setup on a remote computer, use the ch command in the Special Administration Console (SAC), or press ESC+TAB. You can use either of these methods to view one of the three setup logging channels.
  • If GUI-mode Setup pauses, use the cmd command in SAC to open a command-prompt channel. You can then use this command-line environment to navigate the system, and, if necessary, repair the $winnt$.sif file located in the systemroot\System32 folder.

Notes

  • When you are using GUI-mode Setup, you must perform an unattended Setup. You can then respond from your local computer when the remote computer prompts you for input during setup. If you do not perform an unattended Setup, GUI-mode Setup will fail.
  • If setup fails, but the remote computer is still responding, there might be a problem with the setup files.
  • If you examine the setup log channels and are still unable to determine the reason for the pause or failure of GUI-mode Setup, you might need to monitor a local display to determine the cause.

Related Topics


Resolve system resource problems using SAC

Microsoft Windows Graphic

To resolve system resource problems using SAC

  • Use the T command in Special Administration Console (SAC) to view the processes that are running on the remote computer, the amount of CPU time they have consumed, and the amount of memory they are using. See "Task list headings" in Related Topics for more information on analyzing the output from the T command.
  • Use the R and L SAC commands to modify the priority of any processes that might be preventing the use of in-band tools on the remote computer.
  • Use the K SAC command to end a process that is causing a problem on the remote computer.
  • If the problem persists, or if you do not know which process is causing the problem, use the restart SAC command to restart the remote computer.

Notes

  • Before you use SAC to resolve a system resource problem, first try using in-band tools. Use SAC only if using in-band tools fails to resolve the problem.
  • You might be able to determine which processes are consuming the most resources by comparing two consecutive task lists.

Related Topics


Respond to a Stop error message

Microsoft Windows Graphic

To respond to a Stop error message

  • View the Stop error message information remotely, and use !Special Administration Console (!SAC) to restart the remote computer. Viewing the kernel log with the D command can help to determine the cause of the error, especially if the Stop error message appeared during the startup process.

Notes

  • To display !SAC, press ENTER when viewing the Stop screen.
  • You can manually generate a Stop error message and force a memory dump file to be created by using the SAC crashdump command. To do so, however, you must have crash dump enabled.

Related Topics


Respond if SAC and !SAC become unavailable

Microsoft Windows Graphic

To respond if SAC and !SAC become unavailable

Depending on the remote computer's hardware configuration, one or more of the following approaches can be helpful if Special Administration Console (SAC) and !SAC become unavailable. For more information, see your hardware manufacturer's documentation.

  • Perform diagnostic procedures using the service processor's out-of-band tools if a service processor is present, and if the tools are available.
  • Restart the remote computer by using the interface supplied by a service processor, if one is present.
  • Restart the remote computer by using the interface supplied by a power switch or an uninterruptible power supply (UPS) with remote computer management capabilities, if one is present.
  • If none of these approaches is appropriate, start the remote computer by pressing the power button.

Note

  • If you restart the remote computer using a power switch or UPS, its firmware must be configured to turn on when power is restored.

Related Topics


Change channels

Microsoft Windows Graphic

To change channels

  • Press ESC+TAB.

Notes

  • To return to the Special Administration Console (SAC) channel, press ESC+TAB, and then press 0.
  • To learn more about managing your system using Emergency Management Services channels, type:

    ch -?

Related Topics


Concepts

This section covers:

  • Emergency Management Services overview
  • System-state diagram
  • Understanding Emergency Management Services
  • Setting up Emergency Management Services
  • Using Emergency Management Services
  • Resources


Emergency Management Services overview

Emergency Management Services is a new feature that is included with the Microsoft® Windows® Server 2003 family. You can use this feature to perform remote-management and system recovery tasks when the server is unavailable through the network or other standard remote-administration tools and mechanisms. Emergency Management Services is available for x86-based and Itanium-based systems.

When a server is operating normally, you can manage it remotely by using a variety of administrative tools that are provided in your Windows Server 2003 operating system. Using these tools to access and manage the server is referred to as in-band management. It usually requires a network that is fully available. For more information on this topic, see In-band management.

When the network is unavailable, you can use Emergency Management Services to access and manage the server. You do so through an out-of-band connection. This method does not require operating-system network drivers. In addition, you can use an out-of-band connection to troubleshoot the server when it is not fully initialized and functioning. Typically, you can do this without being physically present at the computer. When the appropriate out-of-band hardware is in place, the server requires physical access only when hardware must be installed or replaced. Emergency Management Services also eliminates the need for a keyboard, mouse, monitor, or video adapter on the remotely administered server. Emergency Management Services is available with or without a video card. For more information about this topic, see Out-of-band management.

With Emergency Management Services, you use a straightforward but powerful terminal text mode instead of a graphical user interface (GUI). As a result, you can use Emergency Management Services with a wide range of communication media (including serial connections) and current out-of-band infrastructure (including terminal concentrators and terminal emulators). It also provides interoperability with other platforms, such as UNIX.

Emergency Management Services features are fully or partially available when the operating system loads, when it is active (setting up and starting up), and when it is in distress (responding improperly or experiencing a Stop error). For a visual overview of these situations, see the System-state diagram.

For additional information on how to integrate Emergency Management Services into your infrastructure, see "Deploying Emergency Management Services" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/).


System-state diagram

System-state diagram

System-state diagram conventions

  • The shaded boxes represent situations in which Emergency Management Services features are fully or partially available.
  • The dashed lines represent transitions into distress or failure states. The operating system might not be able to recover unless assisted. You can use Emergency Management Services to attempt remote recovery if the system is at least partially functioning.
  • The ability to manage the system remotely, which is represented by the non-shaded boxes, varies by system. Consult your system documentation to determine whether your system includes features, such as firmware redirection or a service processor, that can affect your ability to manage the system remotely.
  • The solid lines represent normal or expected behavior. In these situations, you would expect the computer to turn on, initialize system firmware, and start the operating system without problems.
  • The numbers are a sequential representation of the system states.
  • For information about system-recovery procedures that correspond to situations represented in this diagram, see How to.


Understanding Emergency Management Services

This section covers:

  • Remotely administered servers
  • In-band management
  • Out-of-band management
  • Emergency Management Services components
  • RIS and PXE requirements
  • Firmware console redirection
  • Emergency Management Services console redirection
  • Service processor console redirection


Remotely administered servers

For servers equipped with the proper firmware, Emergency Management Services provides functionality that you can use to administer a server remotely. You can usually do so without a local keyboard, mouse, or display device. Except for hardware maintenance and replacement, all administrative functions that you can accomplish locally should be available remotely. This includes starting your system and performing system-recovery tasks.

Remote administration does present security issues, however. For more information on securing a system that is managed with Emergency Management Services, see Best practices for implementing security measures.

You should be able to perform the following administrative tasks on a remotely administered server:

  • Start up a server.
  • Change basic input/output system (BIOS) settings.
  • View power-on self test (POST) results.
  • Install Windows using a standard mechanism such as Remote Installation Services (RIS).
  • Select which operating system to start.
  • Manage Windows using standard management tools such as Windows Management Instrumentation (WMI), Terminal Services Remote Desktop for Administration, Microsoft Management Console (MMC), Telnet, Windows Script Host, and non-Microsoft tools.
  • Manage a Windows Server 2003 operating system when it is unavailable over the network.
  • View system Stop errors.
  • Reset a server.

To support operations performed without a keyboard, mouse, or display device attached to the system, Windows Server 2003 operating systems are able to boot without most video card support. For Advanced Configuration and Power Interface (ACPI) systems, the Windows Server 2003 family supports operating without a legacy keyboard controller. Universal serial bus (USB) systems running these operating systems can also support optional keyboard and mouse attachments. Consult your hardware documentation to determine whether your system supports this functionality.

Windows Server 2003 operating systems use the out-of-band management port to support Remote Installation Services (RIS). This makes it easier to install and repair servers remotely. For more information about RIS, see RIS and PXE requirements.

Managing a server that is running normally is referred to as in-band management. It typically involves connecting through the network directly to the server. A server that is functioning normally can be administered remotely with tools provided in the Windows Server 2003 family and listed earlier in this topic.

Troubleshooting a server that is not functioning normally often requires out-of-band management because you must access the server without relying on the network. To perform out-of-band management, you must establish a secure connection through a phone line or serial port, or through an additional network connection (possibly on a secondary network). The goal of out-of-band management is always to return the server to a fully functioning state where in-band connection is available.

Although you can use Emergency Management Services to manage the server remotely when the system is not functioning normally, Emergency Management Services must be set up and configured with the appropriate hardware and firmware. This is necessary so you can access the full range of its out-of-band management capabilities. When you have the proper hardware and Emergency Management Services configuration, out-of-band console input/output (I/O) support is provided for all kernel components, the loader, Setup, Recovery Console, and Stop errors.

When the server is functioning properly, support is also provided for a text-mode management console called Special Administration Console (SAC). For more information, see Emergency Management Services components.

For more information about hardware requirements for Emergency Management Services, see Selecting hardware for Emergency Management Services.


In-band management

Windows Server 2003 operating systems provide a variety of in-band tools you can use to manage computers remotely.

Unlike out-of-band connection, in-band connection is available only when the server is initialized and functioning properly. In-band connection relies on operating-system network drivers to establish computer connections.

The most common in-band remote-management hardware device is the network adapter. Analog modems and Integrated Services Digital Network (ISDN) adapters are also classified as network adapters.

You can use remote-access connections to manage servers. The remote-access connection is made through the in-band port that resides on the target server.

You can use the following administrative tools to perform remote-management tasks through an in-band connection:

  • Microsoft Management Console (MMC)
  • Systems Management Server
  • Telnet
  • Terminal Services Remote Desktop for Administration
  • Windows Management Instrumentation (WMI)
  • Remote Command Service (Rcmd.exe and Rcmdsvc.exe). For more information on this tool, see Windows Resource Kit Tools Help.

You can also use appropriate non-Microsoft management tools to perform remote management tasks through an in-band connection.

If you lose the ability to manage your server through an in-band connection, you can manage the server using an out-of-band connection. For more information on this topic, see Out-of-band management.


Out-of-band management

When you are unable to manage a server over an in-band connection, you can access the server through an alternate but reliable connection called an out-of-band connection. An out-of-band connection does not depend upon operating-system network drivers, and is available even when your server has not loaded or is not functioning properly.

The following list describes situations in which you cannot use in-band management, and where it might therefore be appropriate to use out-of band management:

  • The system is turned off. Because Emergency Management Services is unavailable, special hardware or firmware is required to manage systems in this situation.
  • The basic input/output system (BIOS) is conducting the power-on self test (POST). Because Emergency Management Services is unavailable, special hardware or firmware is required to manage systems in this situation.
  • The server is not functioning properly due to a Stop message event.
  • The server is very low on resources, which causes the network driver to be very slow or makes it unable to respond to requests.
  • The network stack is malfunctioning or has failed.
  • An operating-system component is running (such as the loader or Recovery Console) that does not support in-band communication.
  • The server is not yet fully initialized

The serial port is the hardware interface most commonly used by Emergency Management Services. There are several advantages to this. First, the serial port is simple and reliable enough to allow flexibility and availability. Second, the communication standards that govern serial ports are well defined. This makes interoperability with non-Microsoft systems such as UNIX possible. The third advantage is that most x86-based servers have at least one serial port.

For more information about in-band connections and in-band administrative tools that are available in Windows Server 2003 operating systems, see In-band management.


Emergency Management Services components

Emergency Management Services consists of components that are standard features of Windows Server 2003 operating systems, and to which console redirection functionality has been added. Emergency Management Services also includes two remote-management consoles that are unique to it.

Components that support Emergency Management Services console redirection

The components that support Emergency Management Services console redirection include Setup loader, text-mode Setup, the Recovery Console, Remote Installation Services (RIS), loader, and Stop error messages. When the operating system is configured to run with Emergency Management Services, these components will redirect their output to the out-of-band management port and to the video card, if one is attached. Emergency Management Services is available, however, with or without a video card. All Emergency Management Services output is accessible using a terminal emulator. For more information about console redirection, see Emergency Management Services console redirection.

There are also Emergency Management Services-specific versions of the Startrom.com file that is used in Remote Installation Services (RIS) installations. For more information about this, see RIS and PXE requirements.

Remote-management consoles: SAC and !SAC

The two remote-management consoles designed for Emergency Management Services are Special Administration Console (SAC) and !Special Administration Console (!SAC). You access these consoles through an out-of-band remote management port using terminal software that supports VT-UTF8, VT100+, or VT100.

Special Administration Console (SAC)

Special Administration Console (SAC) is the primary Emergency Management Services command-line environment hosted by Windows Server 2003 operating systems. It is separate from the command-line environment and provides different functionality.

Because SAC is available early in the boot process, you can use it to manage the server during normal system operation and initiation of most Windows Server 2003 family components. You can also use it when the system is in Safe Mode and during GUI-mode Setup. When Emergency Management Services is enabled, SAC remains active as long as the kernel is running.

SAC provides a set of commands you can use to perform a number of management tasks that help return your system to a normally functioning state. These tasks include:

  • Restarting or shutting down the server.
  • Viewing a list of processes that are currently active.
  • Ending processes.
  • Setting or viewing the Internet Protocol (IP) address of the server.
  • Generating a Stop error to create a memory dump file.
  • Starting and accessing command prompts.

For more information about using SAC commands, see Special Administration Console (SAC) and SAC commands.

!Special Administration Console (!SAC)

!Special Administration Console (!SAC) is an auxiliary Emergency Management Services command-line environment that is hosted by Windows Server 2003 operating systems. It also accepts input and sends output through the out-of-band port. !SAC is a separate entity from both SAC and Windows Server 2003 family command-line environments. After a specific failure point is reached, Emergency Management Services components determine when the shift should be made from SAC to !SAC. !SAC becomes available automatically if SAC fails to load or is not functioning.

!SAC provides a subset of SAC commands you can use to restore system functionality during a failure. Its two primary functions are:

  • To redirect Stop error message text.
  • To restart the computer if SAC becomes unavailable.

For more information about using !SAC commands, see !Special Administration Console (!SAC) and !SAC commands.

Windows command-prompt channels and Emergency Management Services

The Special Administration Console Helper service (Sacsvr) is a user-mode service you can use to create Windows command-prompt channels when you type cmd at the SAC prompt. With the command-prompt channels, you can use in-band tools on a remotely administered server when an in-band connection is not available.

For example, when the network is down, you can still run text-based utilities as you would through Telnet. These tools include command-shell utilities such as dir, and text-based console programs such as the boot configuration utility (Bootcfg.exe). You cannot run programs with a graphical user interface (GUI) such as Notepad.exe, however.

Although access to in-band tools through the command-prompt channels provides extensibility and convenience, it does not guarantee that the tools will perform as reliably as they would when run over an in-band connection; the out-of-band functionality and robustness of Emergency Management Services applies only to SAC. In addition, Windows command-prompt channels require system resources, which might cause SAC to be available but the command prompt to be unavailable.

To use a command-prompt channel, you must provide valid logon credentials to a local or domain account, and log on to each command-prompt instance. Press ESC+TAB to switch back and forth between the command prompt channels and SAC. If a command prompt channel becomes unresponsive, use the SAC K (end) command to close it; you can then open another command prompt channel.

For more information about the SAC commands for managing channels, see Special Administration Console (SAC) and SAC commands.

Setup log access

SAC provides access to the setup logs during GUI-mode Setup. You can press ESC+TAB to switch between the setup logs and SAC. When accessing the setup logs from Emergency Management Services, you can see which portions of Setup have completed and whether any errors have occurred. This is a very useful way to check the progress of your setup and to diagnose setup failures.

The three setup log channels are as follows:

setuplog.txt
Monitors setup progress.
setupact.log
Displays any warnings during setup.
setuperr.log
Displays any errors that might occur during setup.


RIS and PXE requirements

Remote Installation Services (RIS) supports remote installations of Windows Server 2003 operating systems. This means that you can initiate RIS-based installations remotely on a computer without being physically present at the computer. RIS eliminates the need to use either the operating system CD or a floppy disk containing a Winnt.sif file. For more information, see Enabling Emergency Management Services during a new installation.

  • RIS support is available on both x86 and Itanium-based systems.

For remote installations to be possible, the client computers must have a network adapter that is Pre-Boot eXecution Environment (PXE) capable. You can then perform installations using a network connection on systems without CD-ROM drives and on systems that have non-formatted or non-partitioned hard disks.

The firmware should recognize the PXE-capable network adapter as a valid boot device and as part of the boot order selection. In addition, the firmware should provide the option of using the F12 key to initiate a remote boot using a keystroke, thus circumventing the boot order. You can use this ability to change the boot order to implement emergency recovery procedures if necessary.

Startrom.com

The Startrom.com file is the first file that an x86-based RIS client downloads to begin the boot process. There are multiple versions of this file. Based on the PXE capabilities of your firmware, you can use Emergency Management Services–specific versions of Startrom.com to make use of console redirection for x86-based RIS clients. The Boot Information Negotiation Layer service (BINLSVC) creates an answer file that allows the rest of Setup to run without user input. Itanium-based RIS clients do not use Startrom.com, however. Instead, you can configure the Extensible Firmware Interface (EFI) to redirect output, and then use the PXE-capable network adapter to boot the computer.

Although you can use the Startrom.com files with systems that are not designed to work with Emergency Management Services, it is better to rely on the firmware to redirect its console output to the out-of-band management port and to use a standard Startrom.com file. This allows Startrom.com to be more flexible in its use of baud rates.

  • Hdlscom1.com and Hdlscom2.com. For systems that do not support firmware console redirection, these files display the Press F12 for network boot prompt, using console redirection to serial port 1 or 2. Users can either press F12 to proceed with the boot process, or they can exit the boot process by not pressing F12. If a user presses the F12 key when prompted, Hdlscom1.com and Hdlscom2.com cause the PXE client to boot into the Client Installation Wizard only when the basic input/output system (BIOS) attempts a network boot. These files are installed by default with RIS.
  • Hdlscom1.n12 and Hdlscom2.n12. For systems that support firmware console redirection, these files do not display the Press F12 for network boot prompt and do not wait for user input. When you use one of these files, the PXE client will always boot into the Client Installation Wizard when the BIOS attempts a network boot.

All Emergency Management Services–specific versions of Startrom.com rely on the BIOS to redirect their output to the out-of-band management port and to the video card, if one is attached. Emergency Management Services is available with or without a video card.

To use a Hdlscomx.com or Hdlscomxn12 file, you must first rename it to Startrom.com, and then copy it to the BINLSVC server. By default, these files are located in the ServerName\reminst\oschooser\i386 folder, where ServerName is the name of the RIS server running the BINLSVC.

Client Installation Wizard

The Client Installation Wizard automatically directs its entire user interface through the out-of-band port and a local console if one is attached to the computer. The Client Installation Wizard determines which out-of-band port to use by either reading the Serial Port Console Redirection (SPCR) table (if available) or by using the same port as Startrom.com. For more information, see Enabling the SPCR table.

For more information about RIS, see Remote Installation Services (RIS).


Firmware console redirection

Firmware can provide redirection before the operating system starts. See the System-state diagram for a visual overview of how firmware and Emergency Management Services console redirection work together.

Types of firmware include both basic input/output system (BIOS) for x86-based computers and Extensible Firmware Interface (EFI) for Itanium-based computers. You can perform the following remote-management tasks using firmware console redirection:

  • View the power-on self-test (POST) status remotely. Typically, computers with firmware that supports console redirection allow a system to complete the POST without a keyboard, mouse, or display device attached.
  • View and edit firmware settings remotely. You can use the built-in firmware configuration program to change computer hardware settings.
  • Start a Remote Installation Services (RIS)–based setup. If the firmware supports Pre-Boot execution Environment (PXE), you can use firmware console redirection to initiate Remote Installation Services (RIS)–based setups. In order to support PXE, the firmware must recognize the network adapter as a boot device. If necessary, the firmware must also allow you to change the settings of the BIOS boot order. For more information, see RIS and PXE requirements.
  • Respond to the Press any Key to Boot from CD prompt remotely when starting your computer. You can do this by using the operating system CD. Before you begin a CD-based Windows Server 2003 operating system setup, enable firmware console redirection so you can view and respond to this prompt remotely. Your computer's BIOS must support the bootable CD (no emulation mode) format. Check with your computer manufacturer if you do not know whether your BIOS includes this feature. The BIOS specifies the boot order. The CD-ROM should be listed as the first boot device. Emergency Management Services is self-configured during a bootable CD installation by reading the Serial Port Console Redirection (SPCR) table.

Notes

  • The firmware must be able to release control of the serial port to the operating system when the operating system starts.
  • Firmware console redirection is typically available in text mode only.

Without firmware console redirection, you cannot perform out-of-band remote management during the period of time between system restart and the initial load phase of the Windows Server 2003 operating system. When firmware redirection is coupled with Emergency Management Services, however, you can manage and monitor a server remotely as soon as the POST process begins and until the operating system components are initialized. It is recommended that the firmware support the SPCR table. For more information, see Enabling the SPCR table.


Emergency Management Services console redirection

Windows Server 2003 family components such as the Windows loader (Ntldr) can provide Emergency Management Services console redirection. Console redirection makes video output appear in text format when the output is sent to the out-of-band port and local monitor, if one is attached. The computer continues to receive keyboard input from the out-of-band port and the local keyboard, if attached. While the operating system is booting, the console takes over redirection from the firmware. See the System-state diagram for a visual overview of this process.

Important

  • Your computer must have firmware console redirection for you to be unable to view information from the remotely administered server until the operating system starts. For more information, see Firmware console redirection.

Emergency Management Services does not provide console redirection for the following:

  • The Press any key to boot from CD prompt that appears when you start your system by using the operating system CD.
  • The Windows Server 2003 family GUI-mode Setup.
  • Disk related error messages caused by problems such as a damaged master boot record (MBR).
  • Startrom.com at baud rates greater than 9600 baud.
  • For Itanium-based systems, Emergency Management Services relies on the firmware to redirect the operating system boot menu.

With Emergency Management Services console redirection, you can manage a server remotely through an out-of-band connection to do the following:

  • Verify the initial load of Windows Server 2003 family components when administrative tools for in-band management are not yet available.
  • For x86-based systems, select an operating system to load on multiple boot systems.
  • View the progress of the Windows Server 2003 family text-mode Setup.
  • For systems without firmware console redirection, respond to the F12 prompt remotely when using Remote Installation Services (RIS) to initiate a Setup program.
  • Respond to Windows Server 2003 family text-mode Setup prompts.
  • View Stop error messages remotely when a system problem has occurred.
  • Use the Recovery Console to troubleshoot startup problems remotely.
  • Start and access command prompts.


Service processor console redirection

If your system includes a service processor, enhanced out-of-band management features, including console redirection, might be available to you. When selecting service processor hardware to use with Emergency Management Services, ensure that the hardware supports the following functions:

  • Turn the computer on.
  • Turn the computer off.
  • Reset.
  • Console redirection.
  • Field-replaceable components (for example, service processors that are installed in sockets rather than soldered permanently in place).

For more information about selecting a service processor to complement Emergency Management Services, see Service processors. If your computer is currently equipped with a service processor, check your system documentation for more information about the out-of-band management features it provides.


Setting up Emergency Management Services

This section covers:

  • Selecting hardware for Emergency Management Services
  • Configuring hardware for Emergency Management Services
  • Selecting client terminal software for Emergency Management Services
  • Enabling Emergency Management Services


Selecting hardware for Emergency Management Services

Emergency Management Services must be integrated with properly designed hardware in order to manage Windows Server 2003 operating systems completely and successfully.

The three key areas you must address to fully integrate your platform with Emergency Management Services are as follows:

  • Ensure that you have appropriate hardware for an out-of-band management port. Windows Server 2003 operating systems support a legacy serial port and hardware that uses the Universal Asynchronous Receiver/Transmitter (UART) interface provided by a service processor.
  • The user interface for the system firmware and out-of-band management service processor should use the same communication medium as Emergency Management Services. If the firmware is using the out-of-band port, the firmware should deliver the medium over to Emergency Management Services cleanly after the power-on self test (POST) process has completed. The firmware should also use the same terminal conventions as Emergency Management Services, using the same keystrokes to represent keys such as F12. These criteria are recommended, not required. For more information, see VT-UTF8, VT100+, and VT100 conventions.
  • The firmware must be able to pass the configuration settings of the out-of-band port to the operating system using the Serial Port Console Redirection (SPCR) table. The firmware stores configuration settings in the SPCR table, and the operating system reads them if the appropriate settings are in the Boot.ini file or the Extensible Firmware Interface (EFI). For more information, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/).
For additional information about selecting hardware, see Support Resources.

This section covers:

  • Serial ports
  • Service processors
  • Terminal concentrators


Serial ports

The most common out-of-band hardware interface is the serial port, also called the COM port. This serial port must be a 16550 Universal Asynchronous Receiver/Transmitter (UART). If your system firmware is compatible with Emergency Management Services, it is recommended that you configure it to use the same serial port settings. Emergency Management Services and the Windows debugger cannot share the same COM port. The system can have only a single out-of-band management port. Windows Server 2003 operating systems do not support a configuration in which one out-of-band port sends outgoing communication and a different out-of-band port (on a second device) receives incoming data.

For more information about serial ports, see:

  • Enabling firmware console redirection
  • Configuring serial ports

For additional information about selecting hardware for Emergency Management Services, see:

  • "Emergency Management Services" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/)
  • Support Resources


Service processors

To use Emergency Management Services console redirection, Special Administration Console (SAC), or !Special Administration Console (!SAC), the operating system loader or kernel must be at least partially functioning. Therefore, when severe system problems cause a computer to completely stop responding, you must have a remote-management medium that can function entirely without the operating system. Service processors integrated onto system motherboards and Peripheral Component Interconnect (PCI) adapters provide such a medium.

Service processors can function this way because they operate independently of the processors in a computer. In addition, they use their own custom firmware and can even use a separate power supply to enhance reliability. You can communicate directly with a service processor through an out-of-band connection.

The management tools, features, and client interfaces provided by service processors differ from one manufacturer to another. They can range in complexity from a simple Telnet console to a rich Web-browser environment. You should evaluate the management features and troubleshooting tools provided by a service processor to ensure that they meet the needs of your organization.

Service processors can also provide support through media that are more complex than serial ports, such as Transmission Control Protocol/Internet Protocol (TCP/IP) on Ethernet. Service processors are typically integrated into system motherboards or add-in PCI adapters and function separately from the system's CPU.

Some service processors are also called Application Specific Integrated Circuits (ASICs). Depending on their original equipment manufacturer (OEM), service processors or ASICs can be implemented with many different types of out-of-band connection ports, including serial ports, Universal Serial Buses (USBs), modem connections, and RJ-45 Ethernet ports. The type of out-of-band connection you use determines which additional components are required to allow out-of-band access to your servers.

When selecting service processor hardware for use with Emergency Management Services, verify that the following functions are supported:

  • Turn on the computer
  • Turn off the computer
  • Reset
  • Access to Emergency Management Services
  • Console redirection
  • Field replaceable units (FRUs); for example, a hard disk

Internal hardware interface requirements

To provide complementary functionality, Emergency Management Services and service processors or ASICs must be available for remote management. The service processor must provide a pass-through connection between the operating system and the remote management client. With this functionality, you can use both Emergency Management Services and the service processor through a single connection medium.

The service processor must include an appropriate 16550 or 16450 Universal Asynchronous Receiver/Transmitter (UART) in its system input/output (I/O) as an internal hardware interface for Emergency Management Services. This UART hardware must be available to Emergency Management Services at all times, including when the operating system loader is running, when the operating system is fully loaded, and when a Stop error has occurred.

The UART interface must be fully described in the Serial Port Console Redirection (SPCR) table, or, in Itanium-based systems, through the Extensible Firmware Interface (EFI) console device path. For more information, see Enabling the SPCR table.

User interfaces for service processors

Original equipment manufacturers (OEMs) can define a range of user interfaces for their service processors. Serial ports and RJ-45 Ethernet interfaces are examples of two such user interfaces. Some interfaces might support more than one communication protocol; for example, Ethernet supports Telnet and Hypertext Transfer Protocol (HTTP), as well as others. Other interfaces use a single communication channel, such as a serial port.

With an interface that uses a serial port as its communication channel, you can use only one out-of-band management tool (Emergency Management Services or the service processor) at a time. Emergency Management Services and the service processor must share the interface reliably. Integration between Emergency Management Services and the service processor is especially important during the operating system's boot process because you are interacting with both Emergency Management Services and the service processor using the same serial interface. In addition, you are relying on both Emergency Management Services and the service processor to follow the same I/O conventions.

After a system restart, the service processor must release control of the serial port to Emergency Management Services. For this to occur, internal UART hardware must be available so that the service processor and Emergency Management Services can communicate with each other. If the service processor and Emergency Management Services both use VT100 conventions, communication will be successful, and the service processor can be invoked and exited. For more information about this, see VT-UTF8, VT100+, and VT100 conventions.

When the user interface is a multiple-channel interface, such as an RJ-45 Ethernet, the requirements for providing access to Emergency Management Services change. Access to Emergency Management Services must be available simultaneously with the out-of-band functionality provided by the service processor. The terminal interface that you use to manage the server should support VT100+ conventions.

Power switches or uninterruptible power supplies (UPS) with remote computer management capabilities

A power switch or uninterruptible power supply (UPS) provides control of the power that is supplied to the server. It can also provides basic remote-management capabilities, such as the ability to reset the system or turn it off. A power switch or UPS can also allow the serial communication between a management system and a server to pass through its port. That is, the port on the computer used for management can have a serial connection to an external serial port on the UPS, which can then have a serial connection to the server.

If you use a power switch or a UPS, it must provide unrestricted communication between the management computer and the Windows Server 2003 family out-of-band tools. A power switch or UPS can interrupt the out-of-band tools by using an escape sequence that is sent by the management computer. To use a power switch or UPS, the server must be configured to boot automatically when power is applied.

The following requirements must be met before you use a power switch or UPS with Emergency Management Services:

  • The UPS must be able to reset the system.
  • The UPS user interface must support the escape sequences and VT100+ conventions.

It might be preferable for the power switch or UPS to provide terminal concentrator functionality. For more information, see Terminal concentrators.

The following resources provide additional information about selecting hardware for Emergency Management Services:

  • "Emergency Management Services" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/)
  • Support Resources


Terminal concentrators

A terminal concentrator is a hardware device that consolidates serial access to multiple servers into a single networked device. You can use this device to monitor a large number of servers simultaneously from one location.

Terminal concentrators include many serial ports connected to multiple servers using null modem cables. Typically, you access terminal concentrators over the network through the Telnet protocol. Terminal concentrators provide an interface through which you can remotely view data on multiple servers that use serial ports as their out-of-band connection.

Terminal concentrators can improve your management of servers because they can establish in-band connections to the servers and then perform out-of-band management tasks. In addition, terminal concentrators make it easier to manage servers for the following reasons:

  • You can use terminal concentrators to manage multiple servers without needing to be within a serial cable's distance to the computer.
  • Several administrators can simultaneously view the output of different servers.
  • Using an out-of-band connection, you can use terminal concentrators to monitor servers methodically. You can also manage multiple servers from one location.

Several companies manufacture terminal concentrators; their setup, features, and configuration details vary. When assessing the appropriateness of a particular terminal concentrator, consider the following:

  • The number of serial ports available.
  • Built-in Telnet security features, such as passwords.
  • Remote-access capabilities.
  • The number of Ethernet ports available.

Telnet security features are not standard across terminal concentrators. If your device does not include security features, consider using a secondary private management network accessible through a direct-dial remote access connection or a virtual private network (VPN) connection. You can also use a router to secure network traffic going to the terminal concentrator.

For more information, see Checklist: Installing and configuring the router and Checklist: Installing and configuring the remote access server.

Using Telnet over Internet Protocol security (IPSec) can enhance security. See Internet Protocol security (IPSec) for additional information.

For more information on terminal concentrators, see Configuring terminal concentrators.

For additional information about selecting hardware for Emergency Management Services, see:

  • "Emergency Management Services" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/)
  • Support Resources


Configuring hardware for Emergency Management Services

This section covers:

  • Configuring serial ports
  • Configuring terminal concentrators


Configuring serial ports

This section covers:

  • Configuring serial port hardware settings
  • Enabling firmware console redirection
  • Enabling the SPCR table
  • Selecting the terminal definition setting


Configuring serial port hardware settings

The serial port, also known as the COM port, is the most common out-of-band hardware interface. For information about selecting serial ports that complement Emergency Management Services, see Serial ports.

Emergency Management Services uses the first serial port (COM 1 at 3F8) by default. If a device already occupies that serial port, you can either move the device to another serial port or use another serial port for Emergency Management Services.

To prepare serial ports for out-of-band communication, you must first verify that motherboard serial ports are enabled. This is important if you have not already attached serial devices to determine whether the ports are working. To conduct this test, follow the manufacturer's instructions on how to access the x86-based basic input/output system (BIOS) or Itanium-based Extensible Firmware Interface (EFI) setup utility. Then navigate to the menu items that pertain to device configuration.

Serial ports allow the configuration of specific hardware resources such as input/output (I/O) addresses and hardware interrupt requests (IRQs). Depending on your system firmware, serial port resources might be user configurable, or they might have Enabled or Disabled as the only choices available. You should configure the appropriate port so it is enabled and at the default settings for a given COM port.

For more detailed procedures and best practices related to configuring serial ports, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/).


Enabling firmware console redirection

With firmware console redirection, your system can redirect text output to the out-of-band port.

Typically, you must enable firmware console redirection in the system firmware settings. Consult the original equipment manufacturer (OEM) or the documentation that came with your computer for information about how to change the firmware settings.

It is preferable for a system to indicate its firmware redirection settings through the Serial Port Console Redirection (SPCR) table. For more information about this topic, see Enabling the SPCR table.

For more information about firmware console redirection, see Firmware console redirection.

For more information about possible firmware settings and setup procedures, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/).


Enabling the SPCR table

The Serial Port Console Redirection (SPCR) table provides information on how the system firmware and the service processor use the out-of-band management port. For example, if the out-of-band management port is a serial port, the SPCR table contains information such as serial port number, baud rate, terminal type, and other settings used for out-of-band communication. If the out-of-band management port is a non-legacy Universal Asynchronous Receiver/Transmitter (UART) interface on a service processor, the SPCR table provides information about the location and type of UART interface.

The SPCR table ensures that there is a smooth transition between the system firmware and Emergency Management Services.

The SPCR table is usually enabled automatically if you have a service processor that supports Emergency Management Services, or you have enabled firmware console redirection. See your original equipment manufacturer (OEM) documentation to determine whether your computer supports the SPCR table and whether you must adhere to special requirements to enable it.

Windows Server 2003 operating systems attempt to configure Emergency Management Services hardware resource settings to match SPCR table settings without user intervention. If your system does not have an SPCR table, you must configure the Emergency Management Services settings to match the firmware settings, providing the operating system with the Emergency Management Services out-of-band port parameters.

For more information about required or recommended settings, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)


Selecting the terminal definition setting

Terminal definition standards ensure that communications between the remotely administered server and the computer that manages it are standardized. For background information on these standards, see VT-UTF8, VT100+, and VT100 conventions.

Be sure to select a terminal definition setting for your firmware or service processor that is compatible with the Windows Server 2003 family and client terminal software. The best setting is VT-UTF8. If VT-UTF8 is not available, the next best choices, given in order of preference, are VT100+ and VT100. For a list of required or recommended settings, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)


Configuring terminal concentrators

A terminal concentrator consolidates access to multiple servers. You can use a terminal concentrator to establish remote out-of-band connections through the Telnet protocol over an in-band network connection. For information about selecting a terminal concentrator to complement Emergency Management Services, see Terminal concentrators.

Telnet security features are not standard across terminal concentrators. If your device does not include security features, consider using a secondary private management network that is accessible through a direct-dial remote access or virtual private network (VPN) connection. You can also use a router to secure network traffic to the terminal concentrator.

For more information, see Checklist: Installing and configuring the router and Checklist: Installing and configuring the remote access server.

You can also use Telnet over Internet Protocol security (IPSec) for increased security. See Internet Protocol security (IPSec) for additional help.

If you choose not to use a terminal concentrator, you can use null modem cables to connect a single networked computer running a Windows Server 2003 operating system to multiple servers running Emergency Management Services.

For more information on selecting and configuring terminal concentrators, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)


Selecting client terminal software for Emergency Management Services

Before you can access Emergency Management Services remotely, you must ensure that you are using compatible client software.

The out-of-band management hardware installed on your server determines which client software you should use. HyperTerminal or other VT-UTF8 terminal emulation software might be an option. For more information, see VT-UTF8, VT100+, and VT100 conventions and the HyperTerminal Help.

If your system has a service processor that requires a specialized client, both the service processor and the client must be capable of displaying Emergency Management Services output. For communication with service processors using RJ-45 Ethernet, Transmission Control Protocol/Internet Protocol (TCP/IP) might be an appropriate choice.

Viewing non-English output from Emergency Management Services

Emergency Management Services supports localized output on non-English versions of Windows Server 2003 operating systems. To view non-English characters, you must have an out-of-band management application that supports the VT-UTF8 terminal definition. HyperTerminal supports the VT-UTF8 terminal type.

For some terminals that support the VT-UTF8 terminal type, you must configure the operating system in order to be able to view output from a server that is a non-English language that is different from the language on your local computer.

For example, if the server runs a Chinese version of the Windows Server 2003 operating system, but the computer you use to manage the server runs an English version of the operating system, it might be necessary to configure the local computer's operating system. This is typically done in Regional and Language Options. The procedure can vary, however, according to the terminal application you use. It might also be necessary to install additional fonts.

For step-by-step information on how to view non-English output from Emergency Management Services, see To view East Asian languages with the VT-UTF8 terminal emulator in Hyperterminal.


Enabling Emergency Management Services

This section covers:

  • Enabling Emergency Management Services during a new installation
  • Enabling Emergency Management Services during an upgrade (x86-based systems)
  • Enabling Emergency Management Services after Setup (x86-based systems)
  • Enabling Emergency Management Services after Setup (Itanium-based systems)


Enabling Emergency Management Services during a new installation

You can initiate an Emergency Management Services embedded installation when you start the computer from the Windows Server 2003 operating system CD if your system supports firmware console redirection and the Serial Port Console Redirection (SPCR) table.

Before you begin a CD-based Windows Server 2003 operating system Setup, enable firmware console redirection. You can then remotely view and respond to the prompt Press any key to boot from CD-ROM, which appears when you start the system using the operating system CD.

Emergency Management Services configures itself during a bootable CD installation by reading the SPCR table. If Emergency Management Services is enabled, you are prompted at the end of text-mode Setup to allow Setup to automatically configure your system without user input. You must choose this option; otherwise, the next portion of Setup, known as GUI-mode Setup, completes only if you provide input through a local monitor and keyboard. After Setup is complete, you can reconfigure the setting appropriately.

If your firmware does not support the SPCR table, you must fully automate your setup. If your firmware supports the SPCR table, and you want to disable Emergency Management Services, you can configure Setup using Unattend.txt and Winnt.sif files.

Unattend.txt and Winnt.sif files

You must have the Unattend.txt and Winnt.sif files if you want to fully automate the remote installation of a Windows Server 2003 operating system.

A sample Unattend.txt file is provided on the operating system CD. You can either use the default settings or customize your installations by modifying or adding parameters. When you edit the Unattend.txt files, insert the parameters in the [Data] section, as shown in the following table:

[Data] Parameter | Possible values
EMSPort={com1|com2|usebiossettings}
  • com1 or com2 (where 1 or 2 specifies serial port 1 or 2). This option is valid for x86-based systems only.
  • usebiossettings
    This is the default value. This parameter instructs the operating system to detect and use SPCR settings. If you use this parameter and an SPCR table is not present, Emergency Management Services is not enabled.
EMSBaudRate=value | The default value is 9600 baud, with the values of 19200, 57600, and 115200 possible, depending on the capabilities of the serial port. This must be used with EMSPort= or the parameter is ignored.

You can create a Winnt.sif file by copying an Unattend.txt file to a floppy disk and renaming it to Winnt.sif. Because CD media is read-only, CD-based Windows Server 2003 operating system installations must read custom setup information from the floppy drive. The table later in this topic lists unattended Setup parameters required for Winnt.sif. When editing a Winnt.sif file, insert the parameters listed in both tables into the [Data] section.

For remote Setup to complete successfully without a local keyboard or monitor, you must configure your setup scripts so they are completely unattended. For more information about unattended Setups, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)

[Data] Parameter | Possible values
Autopartition={0|1} | Allows unattended Setup to choose a partition in which to install. The value must be set to 1 for unattended Setups. If you do not set the value, text-mode Setup stops and waits for your input.
MsDosInitiated={0|1} | Informs the Setup Loader that an unattended installation is occurring directly from the CD. The value must be set to 0 for unattended Setups.
UnattendedInstall={No|Yes} | The value must always be set to Yes for CD-based unattended installations.

Important

  • To use Winnt.sif files, you must set the CD-ROM as the primary boot device and leave the floppy disk containing a Winnt.sif file in the floppy drive.
  • Unattended Setups for Windows Server 2003 operating systems do not pause for user input. With console redirection, you can view text-mode Setup remotely for monitoring purposes.

For specific examples and additional information about creating unattended setups, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)

Remote Installation Services (RIS)

With Remote Installation Services (RIS), you can install a Windows Server 2003 operating system on computers without being physically present at those computers. If the firmware on the target computers supports Pre-Boot eXecution Environment (PXE), console redirection, and the Serial Port Console Redirection (SPCR) table, you can use Emergency Management Services to initiate and complete Setup from remote setup media.

If your firmware does not support the SPCR table, you can configure your Emergency Management Services settings in the RISTNDRD.txt file just as you would configure them in the normal setup scripts, Unattend.txt and Winnt.sif. If your firmware does not support console redirection, you can use special versions of Startrom.com that output to a generic serial port, com1 or com2, at 9600 baud.

For more information about remote installation, see RIS and PXE requirements.


Enabling Emergency Management Services during an upgrade (x86-based systems)

During an upgrade, you can enable Setup on an x86-based system by using Winnt32.exe. After inserting the Windows Server 2003 operating system CD into your computer, map a network drive connection to the path containing the installation files. At the command prompt type:

Drive\i386\winnt32.exe

Drive represents the drive letter assigned to the CD-ROM drive or shared folder. Follow this with one or any combination of the command-line parameters listed in the following table:
[Data] Parameter | Possible values
EMSPort={com1|com2|usebiossettings}
  • com1 or com2 (where the numeral 1 or 2 specifies serial port 1 or 2).
    This option is valid for x86-based systems only.
  • usebiossettings
    This is the default value. This parameter instructs the operating system to detect and use Serial Port Console Redirection (SPCR) settings. If you use this parameter and an SPCR table is not present, Emergency Management Services is not enabled.
EMSBaudRate=value | The default value is 9600 baud, with other values of 19200, 57600, and 115200 possible, depending on the capabilities of the serial port. This must be used with EMSPort= or the parameter is ignored.
Winnt32.exe copies setup files to your system and then prompts you to confirm a restart. After restarting the system, text-mode Setup begins, followed by GUI-mode Setup. During text-mode Setup, you can view setup messages through Emergency Management Services console redirection. During GUI-mode Setup, you can access Special Administration Console (SAC), but you cannot view Setup prompts.

Important

  • Winnt32.exe is a GUI-based tool and does not support Emergency Management Services; you cannot start or monitor Winnt32.exe by using the out-of-band port. For this purpose, you must use a GUI-based tool, such as Terminal Services Remote Desktop for Administration.

For more information about using Winnt32.exe to enable Emergency Management Services, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)


Enabling Emergency Management Services after setup (x86-based systems)

To enable Emergency Management Services after setting up a Windows Server 2003 operating system, you must edit the Boot.ini file to enable Windows loader console redirection and Special Administration Console (SAC). The Boot.ini file controls startup; it is located on the system partition root.

Use Bootcfg (Bootcfg.exe) to edit the Boot.ini file.

To view examples of how to edit the Boot.ini file, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)

You can enable Emergency Management Services console redirection in the Recovery Console. You do this by editing the Winnt.sif file, located in the Cmdcons folder on the system partition root. Note that the Winnt.sif for the Recovery Console is separate from the floppy disk Winnt.sif file that is referenced in Enabling Emergency Management Services during a new installation.

For specific information about setting Recovery Console Bootcfg parameters for Emergency Management Services, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/).


Enabling Emergency Management Services after setup (Itanium-based systems)

To enable Emergency Management Services on Itanium-based installations of a Windows Server 2003 operating system, you must first enable firmware console redirection.

To do so, follow the instructions in your hardware manufacturer's documentation. Then, edit the Extensible Firmware Interface (EFI) boot manager settings using Bootcfg. The Bootcfg command enables Emergency Management Services console redirection and Special Administration Console (SAC).

For more information about using Bootcfg to enable Emergency Management Services, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)


Using Emergency Management Services

This section covers:

  • Special Administration Console (SAC) and SAC commands
  • !Special Administration Console (!SAC) and !SAC commands
  • VT-UTF8, VT100+, and VT-100 conventions
  • Task list headings


Special Administration Console (SAC) and SAC commands

You perform most remote-management and recovery tasks using an out-of-band management port with Special Administration Console (SAC). The server must be at least partially functioning in order to use SAC.

After Emergency Management Services is enabled, SAC is always running unless Emergency Management Services components are prevented from loading properly. If Emergency Management Services components are prevented from loading properly, the server starts !Special Administration Console (!SAC). In addition, a set of SAC commands is available for performing management tasks.

The following prompt appears when SAC is active:

SAC>

For more information, see Emergency Management Services components and !Special Administration Console (!SAC) and !SAC commands.

SAC commands

The following table lists SAC commands that are available for remote management tasks.

Command | Description
ch | Lists all channels.
cmd | Creates Windows command-prompt channels. To use a command-prompt channel, you must provide valid logon credentials. You must log on to each command-prompt instance.
crashdump | Manually generates a Stop error message and forces a memory dump file to be created.
D | Dumps the current kernel log.
F | Toggles the information output by the t-list command, which shows processes only, or shows processes and threads.
I | If no parameters are passed, this command lists Internet Protocol (IP) information. You can configure IP parameters to display or set the IP address, subnet mask, and gateway of a given network interface device by providing the network number, IP address, and subnet information. To do so, use the following format: <network#><IPaddress><subnet>
Id | Displays identification information about the server.
K<PID> | Ends the given process. PID is the process identification number you specify.
L<PID> | Lowers the priority of a process (and any associated child processes) to the lowest possible level.
lock | Restricts access to Emergency Management Services command-prompt channels. You must provide valid logon credentials to unlock a channel.
M<PID><MB-allow> | Limits the memory usage of a process (and any associated child processes) to a specified number of megabytes. MB is the number of megabytes you specify.
P | Causes t-list command output to pause after displaying one full screen of information.
R<PID> | Raises the priority of a process and any associated child processes up by one level.
restart | Restarts the computer.
S | If no parameters are passed, this command displays the current date using the 24-hour clock format. You can set the system time by providing the date and, optionally, the time in this format: mm/dd/yyyy hh:mm.
shutdown | Shuts down the computer. Do not use this command unless you can be physically present at the computer when you are ready to restart it.
T | Lists the processes and threads that are currently running.
? or help | Lists the available commands.

Channel-management commands

The following table lists the subset of SAC commands available for managing out-of-band port channels.

Command | Description
ch | Lists all channels.
ch -si <n> | Changes to the channel with the number, n, which you specify.
ch -sn <name> | Changes to the channel with the name you specify.
ch -ci <n> | Closes the channel with the number, n, which you specify.
ch -cn <name> | Closes the channel with the name you specify.
ch -k <name> | Ends the channel with the name you specify.
<Esc><Tab> | Enables you to change channels.
<Esc><Tab>0 | Returns you to the SAC channel.
ch -? | Displays the channel-management commands Help.


!Special Administration Console (!SAC) and !SAC commands

You can use !Special Administration Console (!SAC) to perform remote management tasks if the Windows Server 2003 operating system stops functioning due to a Stop error message.

The main functions of !SAC are as follows:

  • Redirect Stop error message explanatory text.
  • Restart the system.
  • Obtain computer identification information.

When !SAC becomes available, the following prompt appears:

!SAC>

!SAC includes a subset of SAC commands, which are listed in the following table:

Command | Description
restart | Restarts the server immediately.
D | Displays all log entries (screen pauses at each page of information).
Id | Displays computer identification.
Q | Quits !SAC and resumes normal out-of-band port operation.
? or Help | Lists available commands.

For additional information about topics related to !SAC, see Emergency Management Services components and Special Administration Console (SAC) and SAC commands.


VT-UTF8, VT100+, and VT100 conventions

Industry terminal definition conventions provide a smooth way for you to send commands from the remote management console—usually Special Administration Console (SAC)— to the server. These terminal definition conventions ensure a consistent mechanism for managing systems in all states of operation and failure. Windows Server 2003 operating systems use the commands, which are described later in this topic. The firmware, service processors and client terminal software should also use these commands.

The VT100 Terminal Definition is the standard convention used to configure and conduct emergency management tasks with UNIX-based servers. VT100 does not support all keys on the standard PC 101-key layout, however. The VT-UTF8 convention makes available additional keys that are not provided by VT100 for the PC 101 keyboard. With VT-UTF8, you can also use colors and some standardized escape sequences that are commonly used for management tasks. With VT-UTF8, output sent to the serial port can be localized while UNIX interoperability for English is sustained.

For more information about viewing non-English output from Emergency Management Services, see Selecting client terminal software for Emergency Management Services.

VT100+ is a subset of VT-UTF8 that handles only VT100-compatible characters—that is, American National Standards Institute (ANSI) characters 0 through 127. VT-UTF8 is the preferred terminal type for viewing Emergency Management Services output using a terminal emulator, such as HyperTerminal, and for firmware or service processor output. In either case, if VT-UTF8 is not available, your next best choices are to try VT100+ and then VT100, in that order.

VT-UTF8 and VT100+ keyboard-to-escape-sequence mappings

If you plan to use a VT100, VT100+, or VT-UTF8 terminal emulator to communicate with Emergency Management Services or some other management console, the key mappings provided later in this topic should occur automatically when you press the associated key.

For example, to send an F2 keystroke to a remotely administered server from a terminal using the VT100+ or VT-UTF8 terminal definition, press F2. If you use VT100 emulation software or a terminal emulator that does not support all the key mappings or management escape sequences, however, you can type the escape sequences directly into the terminal. For example, to send an F2 from a VT100 terminal, type <ESC>, and then type 2.

The following table defines these VT100+ and VT-UTF8 key mappings.

VT100+ key | Escape sequence sent
HOME | <ESC> h
END | <ESC> k
INSERT | <ESC> +
DELETE | <ESC> -
PAGE UP | <ESC> ?
PAGE DOWN | <ESC> /
ALT | <ESC>^A
CTRL | <ESC>^C
F1 | <ESC> 1
F2 | <ESC> 2
F3 | <ESC> 3
F4 | <ESC> 4
F5 | <ESC> 5
F6 | <ESC> 6
F7 | <ESC> 7
F8 | <ESC> 8
F9 | <ESC> 9
F10 | <ESC> 0
F11 | <ESC> !
F12 | <ESC> @

Note

  • PC function keys are not equivalent to the VT100 terminal function keys.

The following table lists VT-UTF8 escape sequences used to send special commands:

Action | Escape sequence
Start firmware setup utility | ^F
Reset The computer will reset without shutting down Windows. This command requires either service processor support, or a power switch or uninterruptible power supply (UPS) with remote computer management capabilities. | <ESC>R<ESC>r<ESC>R
Invoke service processor The service processor monitors the serial traffic for this escape sequence. When it detects the sequence, the service processor assumes control of the out-of-band port and immediately sends an acknowledgement sequence (defined later in this table). You cannot use Emergency Management Services until you exit the service processor. This command requires service processor support. | <ESC>(
Invoke power switch or UPS The power switch or UPS monitors the serial traffic for this escape sequence. When it detects the sequence, the power switch assumes control of the out-of-band port and immediately sends an acknowledgement sequence (defined later in this table). You cannot use Emergency Management Services until you exit the power switch. This command requires a power switch or UPS with remote computer management capabilities. | <ESC>)
Power switch, UPS, or service processor acknowledgement After taking control of the out-of-band port, the power switch, UPS, or service processor sends this escape sequence. This indicates that the power switch, UPS, or service processor has assumed control of the port and is ready for interaction. This command requires either service processor support, or a power switch or UPS with remote computer management capabilities. | <ESC>*
Exit power switch, UPS, or service processor; display a user interface (UI) The power switch, UPS, or service processor releases control of the out-of-band port. Before it does so, it might display a user interface message. For example, it might display a warning message such as: "Do you want to save setting and exit? [y/n]." This command requires either service processor support, or a power switch or UPS with remote computer management capabilities. | Q
Exit power switch, UPS, or service processor; do not display a UI The power switch, UPS, or service processor releases control of the out-of-band port without displaying a user interface (UI). | <ESC>Q
For more information, see Selecting the terminal definition setting.


Task list headings

The following table describes the output from the Special Administration Console (SAC) T command, which lists the processes and threads currently running.

Task list heading | Description
User Time | The amount of user-mode time charged to a process since the last time the computer was restarted.
Kernel Time | The amount of kernel-mode time charged to a process since the last time the computer was restarted.
ws | Working set, or the amount of physical memory assigned to a process by the operating system.
Faults | The page faults that have occurred since the last time the computer was restarted. A page fault is an interrupt that occurs when software attempts to read from or write to a virtual memory location that is marked not present.
Commit | The amount of memory that a process is using.
Pri | The default thread priority.
Hnd | The number of handles charged to a process.
Thd | The thread count.
Pid | The process identifier (PID) or numerical identifier that uniquely distinguishes a process while it runs.
Name | The name of the process.
For more information on using the T command, see To resolve system resource problems using SAC.


Resources

For information on how to integrate Emergency Management Services into your existing environment, see "Deploying Emergency Management Services" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/).

For more detailed information on how to select and configure hardware and enable Emergency Management Services, see "Emergency Management Services" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/).

For information about compatible hardware, product support services, and tools, see Support resources.


Troubleshooting

Important

  • You can use the approaches provided in this topic to troubleshoot Emergency Management Services components, not to troubleshoot your system. For information about using Emergency Management Services to troubleshoot your system, see How to.

What problem are you having?

The out-of-band port is briefly unavailable; no status information appears.

Cause: The Windows Server 2003 family components that provide Emergency Management Services load and unload as part of the startup process, which causes components to become briefly disabled. This is called a "black-out period."

Solution: If Special Administration Console (SAC) or !Special Administration Console (!SAC) do not respond, wait for operating system components to initialize before restarting or stopping the system using whatever means are available, such as a service processor or uninterruptible power supply (UPS). If a service processor is present, consult your documentation to determine other diagnostic tools that it provides.

See also: Using Emergency Management Services.

Status information appears, but Emergency Management Services does not respond to terminal input.

Cause: The Windows Server 2003 family components that provide Emergency Management Services load and unload as part of the startup process, which causes components to provide limited functionality. This is called a "gray-out period."

Solution: Gray-out periods might become interactive if the component provides !Special Administration Console (!SAC) functionality. If !SAC does not respond, however, wait for operating system components to initialize before restarting or stopping the system using other means, such as a service processor or uninterruptible power supply (UPS). If a service processor is present, consult your documentation to determine other diagnostic tools that it provides.

See also: !Special Administration Console (!SAC) and !SAC commands.

The kernel debugger disables !Special Administration Console (!SAC). Garbled characters might appear.

Cause: The kernel debugger and !SAC cannot use the same serial port simultaneously. In addition, when a kernel debugger is running, !SAC becomes unavailable because the debugger takes control of the system if a Stop error occurs.

Solution: Use different serial ports for the kernel debugger and !SAC. It is important to specify the correct COMx parameters in the Boot.ini file. You should also disable kernel debuggers on servers during normal operations.