Windows ATM services

Asynchronous transfer mode (ATM) is a standardized set of networking technologies that can be used to build high-speed networks that accommodate Quality of Service (QoS) for connections. Microsoft® Windows® ATM services software allows you to participate in ATM networks if you have ATM adapter hardware installed on your computer.

  • Before you begin using ATM with this computer, see Checklist: Installing ATM services.
  • For tips about using ATM, see Best practices.
  • For help with specific tasks, see How to.
  • For general background information, see Concepts.
  • For problem-solving instructions, see Troubleshooting.


Checklist: Installing ATM services

Step | Reference
Review ATM concepts such as cells, the ATM model, and ATM QoS. | Understanding ATM
Review LAN emulation (LANE). | Configuring LAN emulation
Review TCP/IP over ATM. | IP over ATM (IP/ATM)
Install an ATM adapter on this computer. | To install an ATM adapter
(Optional) Configure the LAN emulation client. | To configure a LAN emulation client
(Optional) Set up IP/ATM connections and install and configure the ATM ARP/MARS service. | To enable a simple TCP/IP-over-ATM connection; To install and configure the ATM ARP/MARS service
Configure permanent virtual connections (PVCs). | To create a permanent virtual connection using ATM
Troubleshoot ATM connections. | Troubleshooting


Best practices

  • Use the default emulated LAN (ELAN).
    On computers running Windows Server 2003 operating systems, asynchronous transfer mode (ATM) services are configured with a default unspecified_ELAN_name group name. If you plan to implement LAN emulation (LANE), it is recommended that you use the preconfigured, default unspecified ELAN group name.

    When you purchase an ATM switch, check the product specifications to ensure that it is preconfigured with the default, unspecified ELAN group name.

  • Use supported ATM adapters.
    Before you buy an ATM adapter, confirm that it is designed for Windows ATM. For more information about compatible hardware, see Support resources.
  • Note configuration parameters before you upgrade from Windows NT 4.0 or Windows 2000 to Windows Server 2003 operating systems.
    Before upgrading from Windows NT 4.0 or Windows 2000, note the following configuration information for each of the LAN emulation clients you plan to upgrade.
    • The ELAN name
    • The media type to be emulated on the LAN
    • ATM addresses for the LAN emulation server (LES) and broadcast and unknown server (BUS) associated with the ELAN
    • The maximum allowable packet size for the ELAN

    After you note these configuration parameters, use the LAN emulation configuration server (LECS) interface on your ATM switch to configure ELANs and their associated parameters, as listed and noted above.

    Next, install the Server software and configure the ELAN name for each LAN emulation client (LEC). For information about configuring the ELAN name, see To configure a LAN emulation client.

  • Use only one ATM ARP/MARS per virtual LAN.
    If your network uses IP/ATM, it is recommended that you configure only one ATM ARP/MARS for each virtual local area network (VLAN) on your network. If you have multiple ARP servers on the same network segment, and your ARP client is configured with the addresses for these servers, the ARP caches could become out of synch. This can render parts of the network unreachable.


How to...

  • Install an ATM adapter
  • Configure a LAN emulation client
  • Create an encapsulated Ethernet permanent virtual circuit
  • Enable a simple TCP/IP-over-ATM connection
  • Configure an advanced TCP/IP-over-ATM connection
  • Install and configure the ATM ARP/MARS service
  • Create a permanent virtual circuit using ATM
  • View ATM connection information


Concepts

This section provides general background information about asynchronous transfer mode (ATM) technologies that are available.

  • ATM overview
  • Understanding ATM
  • Using ATM
  • Resources


ATM overview

This section covers:

  • ATM defined
  • Windows ATM services defined
  • Benefits of ATM


ATM defined

Asynchronous transfer mode (ATM) refers to a number of related technologies, including software, hardware, and connection media. ATM differs from other existing LAN and WAN technologies and was specifically designed to support high-speed communication. ATM allows networks to use bandwidth resources at maximum efficiency while maintaining Quality of Service (QoS) for users and programs with strict service requirements.

The basic components of ATM are the computers that are connected to the ATM network and the devices that connect these computers and ensure that data is transferred successfully. The computers that are connected to the ATM network are called end stations. Routers, DSLAMs, and ATM switches are examples of devices that connect end stations and ensure that data is transferred successfully.

Basic ATM components

Asynchronous means the available network bandwidth is not divided into fixed channels or slots synchronized by a timing mechanism or clock. Devices that communicate using asynchronous communication are not bound by design in terms of their ability to send and receive information at a precise transmission rate. Instead, the sender and receiver negotiate the rate at which they will communicate based on physical hardware limitations and the ability to maintain a reliable flow of information within the network.

Transfer mode refers to the way the information is transferred between sender and receiver. In ATM, the concept of small, fixed-length cells is used to structure and parcel data for transfer. By using cells that contrast directly with the variable-length packet mechanism used by most existing network technologies, ATM assures that connections can be negotiated and managed so that no single data type or connection can monopolize the transfer path.


Windows ATM services defined

  • An ATM UNI Call Manager that conforms to ATM Forum specifications for signaling over ATM and supports the creation of switched virtual circuits (SVCs) and permanent virtual circuits (PVCs).
  • Updated NDIS 5.0 ATM miniport drivers that display the Designed for Microsoft® Windows® logo and provide limited support for installed ATM adapter hardware. For more information, see Designed for Microsoft Windows logo.
  • A LAN emulation client module that conforms to the ATM Forum LANE 1.0 specification, enabling existing programs and protocols designed for use on Ethernet and Token Ring networks to run without modification over an ATM network.
  • An ARP/MARS service that enables the Microsoft TCP/IP stack to resolve ATM addresses to hardware addresses for more direct and efficient use of ATM media. The IP-over-ATM module conforms to RFC specifications for Address Resolution Protocol (ARP) over ATM media, as well as support for a multicast address resolution service (MARS).
  • Enhanced support for TAPI-based programs and services.
  • Support for raw channel access filtering that can be used in program environments that include DirectStreaming.
  • Expanded support for PPP dial-up over ATM media, enabling you to create and use a PPP dial-up connection over any supported ATM adapter that is installed in a computer running a Windows Server 2003 operating system. This feature provides support for ATM over DSL, ATM over cable modem, and other ATM on-demand connectivity possibilities.
  • Access to native ATM services with Winsock 2.0 over ATM. Available through the Windows Sockets ATM Service Provider, Winsock 2.0 allows direct access to ATM services from user-mode programs. It also allows programs that use TCP/IP as a transport protocol to run over ATM networks and interoperate with standard LAN-based IP clients.
  • Encapsulated Ethernet over a permanent virtual connection (PVC), which enables the transmission of Ethernet packets across a PVC on an ATM network adapter. It accomplishes this by acting as an Ethernet adapter to the TCP/IP protocol and using the PVC on the ATM adapter to transfer Ethernet packets.


Benefits of ATM

ATM provides a flexible and scalable solution to the increasing need for quality of service in networks where multiple information types (such as data, voice, and real-time video and audio) are supported. With ATM, each of these information types can pass through a single network connection.

ATM can provide the following benefits:

  • High-speed communication
  • Connection-oriented service, similar to traditional telephony
  • Fast, hardware-based switching
  • A single, universal, interoperable network transport
  • A single network connection that can reliably mix voice, video, and data
  • Flexible and efficient allocation of network bandwidth


Understanding ATM

Asynchronous transfer mode (ATM) refers to a number of related and standardized technologies designed to provide high-speed network communication. For more information on these technologies, see the following sections:

  • ATM networks
  • Example: Switched virtual circuit (SVC)
  • Example: Permanent virtual circuit (PVC)
  • Encapsulated Ethernet over PVC
  • IP over ATM (IP/ATM)


ATM networks

ATM networks are made up of three distinct elements: users (endpoint devices), switches, and interfaces.

In ATM networking, two types of interfaces exist to describe how these elements communicate: user-to-network interfaces (UNIs) and network-to-network interfaces (NNIs).

The UNI and NNI specifications provide a standard signaling method for end stations and ATM switches to communicate.

UNI and NNI signaling

Note

  • The Windows ATM services Call Manager currently supports ATM Forum UNI 3.1. For more information about Windows ATM services, see Windows ATM services defined


Example: Switched virtual circuit (SVC)

The following example shows in detail how an SVC connection is established in an ATM network.

Establishing an SVC

  1. An ATM user, End station A, sends a SETUP message on the virtual channel connection reserved for signaling (VPI=0, VCI=5) to its directly connected ATM switch, ATM switch 1.

    The SETUP message contains:

    • The 20-byte ATM address of End station B.
    • Quality of Service (QoS) parameters needed for connection.

  2. ATM switch 1 analyzes the SETUP message to determine whether it can find a table entry for End station B's switch address and whether it can support the required QoS parameters for the requested connection.

    If ATM switch 1 can find End station B's switch address and support the required QoS parameters for connection, a CALL PROCEEDING message is sent back to End station A.

    If ATM switch 1 either cannot find End station B's switch address or accommodate the connection, a RELEASE message containing standard error codes is sent back to End station A and the call request is rejected.

  3. ATM switch 1 sends the SETUP message (described in Step 1) on the virtual channel connection reserved for signaling (VPI=0, VCI=5) to the next switch in the network, ATM switch 2, on its way to the destination, End station B.

    The SETUP message contains the same ATM address of End station B and all required QoS parameter information as included in Step 1. Additionally, the SETUP message now identifies a new VPI/VCI pair for use between ATM switch 1 and ATM switch 2.

  4. ATM switch 2 receives the SETUP message. End station B is determined to be a directly connected endpoint registered to ATM switch 2. If the QoS required for the requested connection can be accommodated, ATM switch 2 sends a CALL PROCEEDING message back to ATM switch 1.
  5. The SETUP message reaches its final destination, End station B. End station B can respond in either of two ways:
    • If End station B accepts the call, it sends a CALL PROCEEDING message, followed immediately by a CONNECT message back to ATM switch 2.
    • If End station B rejects the call, it sends a RELEASE message back to ATM switch 2. The RELEASE message is passed through the network back to the original source user (End station A) containing standard error codes that describe the reason for rejection.
  6. ATM switch 2 sends a CONNECT ACK message back to End station B, then passes the CONNECT message to ATM switch 1.
  7. ATM switch 1 sends a CONNECT ACK message back to ATM switch 2, then passes the CONNECT message to End station A.
  8. End station A sends a CONNECT ACK message back to ATM switch 1.

The previous example demonstrates a simplified SVC connection using only two intermediate switches, ATM switch 1 and ATM switch 2. In practice, most SVC connections use many intermediate switches. When more intermediate switches are used, each switch forwards SETUP, CONNECT, and RELEASE messages to its downstream neighbor switch, while relaying acknowledgment messages (CONNECT ACK, RELEASE ACK) back to its upstream neighbor switch.

The result of this connection process is a virtual circuit (VC) in both directions between End stations A and B in which:

  • All intermediate switches and ATM user hardware at End stations A and B now support and protectively enforce the QoS communication parameters required for this connection.
  • All intermediate switches (in this case, ATM switches 1 and 2) have been programmed with switch table entries for mapping the series of VPI/VCI pairs used for routing ATM cells between End stations A and B.

If any intermediate switch cannot accommodate the requested QoS connection parameters, a RELEASE message is sent back in the direction of the source user. The RELEASE message contains the standard error codes and frees the resources being reserved at each device in the connection path and at the source.


Example: Permanent virtual circuit (PVC)

Besides using switching and call message signaling to create circuits on demand between any two possible users, you can also permanently configure an ATM virtual circuit between any two specified service endpoints on an ATM network.

PVCs are used extensively by public ATM service providers to create and establish a complex ATM-based infrastructure for their internal networks. In many cases, the internal ATM infrastructure of the network is built using PVCs with actual end-to-end connections occurring over SVCs.

PVCs can also be useful in some private ATM networks where the following types of situations exist:

  • A large campus LAN migrating to a higher-speed ATM backbone. In backbone configurations, connections typically represent a few static configurable switch paths that infrequently change, so permanent configuration of ATM circuits is acceptable.
  • A small WAN with a limited number of sites, each requiring a continuous, dedicated high-speed connection that guarantees a fixed quality of service between site locations. With a circuit permanently established, the ATM switches at both WAN sites do not require the added latency and overhead of using call signaling or connection setup and teardown each time ATM cell traffic data is sent over the network. Sent data can be directly forwarded over PVCs established between each site.


Encapsulated Ethernet over PVC

With encapsulated Ethernet over PVC, you can use an ATM network adapter to send and receive Ethernet packets across a permanent virtual circuit (PVC). Before this technology was developed, you had to install a separate driver for each digital subscriber line (DSL) network adapter to allow an Ethernet network to exchange information with an ATM network. With this technology, you need only provide the virtual path identifier (VPI), the virtual channel identifier (VCI), and the encapsulation type required by your service provider. After you configure these settings, the encapsulated Ethernet PVC transmits data through the ATM adapter. Encapsulated Ethernet over PVC performs the following functions:

  • It acts as an Ethernet adapter to the TCP/IP protocol.
  • It uses a PVC on the ATM adapter to transfer Ethernet packets.
  • It provides a mechanism to transport packets across a DSL.
  • It eliminates the need to install different drivers for different DSL network adapters.

Notes

  • The VPI and VCI must match those configured on your service provider’s switch or router.
  • For information about creating an encapsulated Ethernet PVC, see To create an encapsulated Ethernet permanent virtual circuit
  • For more information about encapsulation, see RFC 2684 on the RFC Editor Web site.
  • XOX


IP over ATM (IP/ATM)

This section covers:

  • IP/ATM overview
  • How IP/ATM works


IP/ATM overview

IP/ATM is a group of services for communicating over an ATM network that can be used as an alternative to LAN emulation. IP/ATM is handled by two main components: the IP/ATM client and the IP/ATM server. The IP/ATM server includes an ATM ARP server and a multicast address resolution service (MARS). IP/ATM network components can reside on a server or an ATM switch.

The main advantage of using IP/ATM is that it is faster than LANE. With IP/ATM, no additional header information is added to packets as they move through the protocol stack. Once an IP/ATM client has established a connection, data can be transferred without modification.

IP/ATM supports the use of a Dynamic Host Configuration Protocol (DHCP) server in the ATM network.


How IP/ATM works

The three general stages of IP/ATM operation are:

  • Client initialization
  • Client registration
  • Data transfer

IP/ATM client startup and registration with a static IP address

The following example describes each step in establishing an IP/ATM connection for a single IP/ATM client with a static IP address:

Client registration
  1. Client A initializes and gets an ATM address from the ATM switch.
  2. Client A connects to the ATM ARP/MARS server and joins the broadcast group. Client A's IP-to-ATM address mapping is added to the ATM ARP server database.
  3. Client A contacts Client B, an ATM end station connected to the network, and begins data transfer.

IP/ATM client startup and registration with DHCP

The following example describes each step in establishing an IP/ATM connection for a single IP/ATM client obtaining an IP address using Dynamic Host Configuration Protocol (DHCP):

  1. The client initializes and gets an ATM address from the ATM switch.
  2. The client connects to the ATM ARP/MARS server and joins the broadcast group.
  3. The client connects to the multicast server and sends a DHCP request. The multicast server broadcasts the DHCP request to all members of the broadcast group. The DHCP server receives the request.
  4. The DHCP server sends a DHCP reply to the multicast server, which then broadcasts the reply to the broadcast group.
  5. The client receives the DHCP reply and then registers its IP and ATM addresses with the ATM ARP/MARS server.
  6. The client is now ready to contact other hosts and begin data transfer.

Note

  • For more information about DHCP, see DHCP.

Broadcasting and multicasting

A broadcast or multicast is used to establish point-to-multipoint connections between the requesting client and multiple end stations on the network. The process of broadcasting and multicasting on IP/ATM can follow two different methods:

  • Direct point-to-multipoint connection

    If a client needs to send an IP packet to a broadcast or multicast IP address, it sends a request to the MARS to resolve the IP address to a list of clients. The MARS sends a group of addresses to a client, allowing it to set up a point-to-multipoint connection.

  • Point-to-multipoint connection through a multicast server

    The MARS can also work with a multicast server. The Windows ATM ARP/MARS has an integrated multicast server, which registers one or more multicast groups with the MARS and receives a list of members in each multicast group from the MARS. The MARS updates the multicast server when clients join or leave a multicast group. When a client makes a multicast or broadcast request to the MARS, the MARS returns only the address of the multicast server. The client contacts the multicast server, which creates a point-to-multipoint connection with the multicast group. The multicast server copies and distributes the packets sent by the client that initiated the point-to-multipoint call to end stations on the multicast list.


Using ATM

This section covers:

  • ATM addressing
  • Configuring LAN emulation
  • Creating switched virtual circuits
  • Creating permanent virtual circuits
  • Modifying ATM defaults
  • Managing ATM from the command line
  • Well-known addresses


ATM addressing

ATM addresses are needed to support the use of switched virtual connections (SVCs) through an ATM network.

At the simplest level, ATM addresses are 20 bytes long and have three distinct parts:

  • Network prefix
    The first 13 bytes identify the location of a specific switch in the network. The use of this portion of the address can vary considerably depending on its address format. Each of the three standard ATM addressing schemes provides information about ATM switch locations differently. These schemes include the data country/region code (DCC) format, the international code designator (ICD) format, and the E.164 format proposed by the ITU-T for international telephone numbering use in broadband ISDN networks.
  • Adapter media access control address
    The next 6 bytes identify a physical endpoint, such as a specific ATM adapter card, using a media access control layer address that is physically assigned to the ATM hardware by its manufacturer. The use and assignment of media access control addresses for ATM hardware are identical to how this addressing works for Ethernet, Token Ring, and other IEEE 802.x technologies.
  • Selector (SEL)
    The last byte is used to select a logical connection endpoint on the physical ATM adapter. Although all ATM addresses fit this basic three-part structure, there are significant differences in the exact format of the first 13 bytes, depending on the addressing format or whether the ATM network is for public or private use.

All of the three ATM address formats that are currently in widespread use (DCC, ICD, and E.164) include the following characteristics:

  • They comply with the Network Service Access Point (NSAP) addressing plan as proposed by the Open Standards Interconnection (OSI) protocol suite of the International Standards Organization (ISO).
  • Each can be used to establish and interconnect privately built ATM networks that support switched virtual connections (SVCs).


Configuring LAN emulation

The basic services for an emulated LAN reside on the ATM switch and workstations with ATM hardware installed. An edge device is required if you plan to connect an Ethernet or Token Ring network to your emulated LAN.

LAN emulation (LANE) component | Where the component resides
LANE services | The LES, LECS, and BUS typically reside on the ATM switch.
LAN emulation client | The LAN emulation client can reside on workstations, ATM switches, and edge devices.

Services

Most of the configuration for LAN emulation is done on the switch running the LAN emulation services. These services include the LAN emulation server (LES), LAN emulation configuration server (LECS), and the broadcast unknown server (BUS). For more information about LAN emulation, see "Asynchronous Transfer Mode" at the Microsoft Windows Resource Kits Web site.(http://www.microsoft.com/) For more information about configuring the LANE services on your ATM switch, see the documentation for your ATM switch.

Client

The LAN emulation client (LEC) software resides on workstations, ATM switches, and edge devices. The LEC is integrated in Windows Server 2003 operating systems and is installed by default if you have an ATM network adapter installed on your computer. After installation is complete, you can install and configure any network protocol driver that works over Ethernet or Token Ring, such as TCP/IP or IPX/SPX. For information about installing and configuring network protocols on your ATM ELAN connection, see To configure a connection to a remote network. For more information about configuring the LAN emulation client, see To configure a LAN emulation client.

Note

  • XOX


Creating switched virtual circuits

Switched virtual circuits (SVCs) are processed by the ATM Call Manager, which handles virtual circuit creation and management. The ATM ARP client and the LAN emulation client support SVCs. Both the LAN emulation client and ATM ARP client are based on the ATM Forum UNI specification.

LAN emulation with SVCs

The LAN emulation client running Windows uses SVCs by default. The client must be configured with a valid emulated LAN name to use SVCs. For more information, see To configure a LAN emulation client.

IP/ATM with SVCs

The ATM ARP client running Windows uses SVCs by default. The ATM ARP client must be configured with the address of the ATM ARP/MARS on the subnet. For more information, see To configure an advanced TCP/IP-over-ATM connection.


Creating permanent virtual circuits

Permanent virtual circuits (PVCs) are typically used by large service providers or in campus backbones to maintain virtual connections in an ATM network.

The ATM Call Manager is used to manually set up PVCs in an emulated LAN or in an IP/ATM network. Use the ATM Call Manager to define the properties for each PVC, including the PVC definition, program usage, and advanced properties.

PVC property | Description
PVC definition | Define the name, virtual path ID, virtual circuit ID, and ATM adaptation layer (AAL).
Program usage | Define the program type for use with the PVC and the basic call-matching characteristics of this PVC.
Advanced properties | Define the Quality of Service (QoS) transmit and receive parameters and specific layer protocols for call matching and answer matching.

For more information, see To create a permanent virtual circuit using ATM.


Modifying ATM defaults

When you install an ATM adapter on computers running Windows Server 2003 operating systems, the default LAN emulation client configuration for ATM services is automatically installed. The LAN emulation client is preconfigured to use the following default emulated LAN (ELAN) group name:

<unspecified ELAN name>

The unspecified_ELAN_name is configured for use with Windows ATM services and by other vendors of ATM switching products. It enables simplified configuration of the ATM LAN emulation client service provided with computers running Windows Server 2003 operating systems, with ATM switches that might be providing LAN emulation services for your network.

Where the unspecified ELAN name is not currently configured or supported by default by other ATM hardware products (such as other switches used on your network), you can do one of the following:

  • Add another supported ELAN name to the list maintained here.
  • Configure the unspecified ELAN name on your ATM switches that provide LAN emulation service to your network.

For more information about changing the settings of your LAN emulation client, see To configure a LAN emulation client.


Managing ATM from the command line

From the command line, you can monitor details of connections and addresses registered by ATM Call Manager on an asynchronous transfer mode (ATM) network. The command line function atmadm allows you to view more detailed connection information than the user interface, which only monitors simple ATM connectivity.

To monitor ATM connectivity:

  1. Click the icon for your ATM adapter in the Network Connections folder.
  2. Click File, and then click Properties.
  3. On the General tab, select the Show icon in taskbar notification when connected check box.

Notes

  • For specific information about using the ATM command-line utility, see Atmadm.
  • When working with the atmadm command, you can list commands currently available for use by typing any of the following: help/?, /?/?, -?/?, ?/?.


Well-known addresses

LANE well-known addresses

LAN emulation clients (LEC) running Windows are preconfigured with the well-known ATM address and virtual channel defined in the ATM Forum specification for obtaining the LAN emulation configuration server (LECS) address. The LEC uses these addresses in the following order:

  1. It can try the well-known LECS address defined in the ATM protocol.

4700790000000000000000000000A03E00000100
  2. It can use the well-known virtual channel defined in the ATM protocol.
  3. It can query using the integrated local management interface (ILMI).

IP/ATM preconfigured address

Windows ATM ARP clients are preconfigured with the ARP/MARS addresses of Windows ATM services. This address is:

4700790001020000000000000000A03E00000200

This number is a well-known E.164 address that Microsoft has selected to simplify configuration and enhance interoperability of the ATM ARP/MARS with other computers running ATM services and XOX or a Windows Server 2003 operating system.


Resources

This section covers:

  • ATM standards
  • ATM updated technical information


ATM standards

There are three major groups defining implementation standards for ATM in networks: the ATM Forum, the IETF, and the ITU-T.

ATM Forum

The ATM Forum is an international not-for-profit group of ATM hardware manufacturers, network software developers, and network service providers, consisting of workgroups that develop and review ATM specifications.

For more information about the ATM Forum and access to ATM Technical Committee specifications, see the ATM Forum Web site.

Internet Engineering Task Force (IETF)

The IETF is the standards organization for the Internet. Within the IETF, the IETF IP-over-ATM working group developed standards for IP traffic over ATM networks. The following chart lists RFCs for implementing IP over ATM.

RFC | Description
2684 | Multiprotocol encapsulation over ATM adaptation layer 5
1722 | RIP version 2 protocol applicability statement
1754 | IP over ATM Working Group's Recommendations for the ATM Forum's Multiprotocol BOF - Version 1
1755 | ATM Signaling Support for IP over ATM
2022 | Support for Multicast over UNI 3.0/3.1 based ATM Networks
2225 | Classical IP and ARP over ATM (makes obsolete RFC 1626 and RFC 1577)

For more information about the IETF and the RFCs regarding IP over ATM, see the IETF Web site.

International Telecommunication Union, Telecommunication Standardization Sector (ITU-T)

The ITU-T defines standards for global telecommunication and services. The ITU-T developed B-ISDN and SONET for broadband transport services.

For additional information about the ITU-T and ITU-T recommendations, see the ITU-T Web site.

Note

  • XOX


ATM updated technical information

The Personal Support Center at the Microsoft Web site provides additional information about ATM. For more information, see Updated technical information.

For more information about asynchronous transfer mode (ATM), see "Asynchronous Transfer Mode" at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)


Troubleshooting

What problem are you having?

Host cannot join an emulated LAN.

Cause: The client and switch must be running a user-to-network interface (UNI) based on parameters outlined in ATM Forum UNI 3.1 or 4.0 specifications. Otherwise, the initial point-to-multipoint (PMP) call setup fails and no connection is made. The LAN emulation client (LEC) provided in the Windows Server 2003 family is based on the ATM Forum UNI 3.1 specification.

Solution: Use the Atmadm utility to determine if the setup call is failing. The Atmadm utility is used to monitor connections and addresses registered by the ATM Call Manager on an asynchronous transfer mode (ATM) network. You can use it to display statistics for incoming and outgoing calls on ATM adapters. If Atmadm displays few or no packets received on signaling and ILMI VCs, check your switch connectivity. For example:

Signaling and ILMI packets sent     = 90718
Signaling and ILMI packets received = 0

See also: To view ATM connection information; Atmadm.

Hosts on my IP/ATM network are unreachable.

Cause: If you have more than one ATM ARP/MARS for each virtual LAN on your network, the ARP caches can become out of synch. This causes clients to be able to only contact clients registered with the same server. Clients registered with another server are unreachable.

Solution: Only use one ATM ARP/MARS for each virtual LAN.

A hardware error occurs when my ATM adapter attempts to initialize.

Cause: Your ATM adapter is running IP/ATM and LAN emulation (LANE) on the same subnet.

Solution: IP/ATM and LAN emulation (LANE) must be configured to run on separate subnets.